Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-10107

Clang warnings when building afw

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw

      Description

      When I build afw using clang on osx I see the following warnings:

      src/detection/PsfFormatter.cc:68:16: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          if (typeid(*storage) == typeid(dafPersist::BoostStorage)) {
                     ^
      src/detection/PsfFormatter.cc:76:21: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          else if (typeid(*storage) == typeid(dafPersist::XmlStorage)) {
                          ^
      src/detection/PsfFormatter.cc:91:16: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          if (typeid(*storage) == typeid(dafPersist::BoostStorage)) {
                     ^
      src/detection/PsfFormatter.cc:99:21: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          else if (typeid(*storage) == typeid(dafPersist::XmlStorage)) {
      

        Attachments

          Issue Links

            Activity

            rowen Russell Owen created issue -
            krzys Krzysztof Findeisen made changes -
            Field Original Value New Value
            Link This issue is child task of DM-10257 [ DM-10257 ]
            krzys Krzysztof Findeisen made changes -
            Resolution Done [ 10000 ]
            Status To Do [ 10001 ] Invalid [ 11005 ]
            krzys Krzysztof Findeisen added a comment -

            Partial duplicate of DM-10257, issue fixed there.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rowen Russell Owen
              Watchers:
              Krzysztof Findeisen, Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: