Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-10182

Build ndarray without Swig support

    Details

    • Type: Story
    • Status: Invalid
    • Priority: Undefined
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ndarray
    • Labels:
      None
    • Templates:
    • Story Points:
      1
    • Team:
      Data Release Production

      Description

      ndarray is being built with -DNDARRAY_SWIG=ON, and hence carrying a Swig dependency. It's (probably) the only thing in lsst_distrib that carries that dependency, and, following the pybind11 merge, it should be unnecessary. Remove it, and drop Swig from the distribution.

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  swinbank John Swinbank
                  Watchers:
                  John Swinbank, Tim Jenness
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Summary Panel