Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-10236

Properly apply the meas_mosaic solution

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_mosaic
    • Labels:

      Description

      As stated in DM-9862, meas_mosaic assumes the 0,0 for each CCD to be the lower left hand corner. LSST uses a different coordinate system so meas_mosaic rotates the wcs into the LSST frame when writing to disk. However the photometric correction is still in the HSC frame, so when applying the meas_mosaic correction we need to rotate the wcs back to the HSC frame. We can then create the photometric correction, rotate it into the LSST frame and apply it to the image. We then rotate the wcs back to the LSST frame.

        Attachments

          Issue Links

            Activity

            rearmstr Bob Armstrong created issue -
            swinbank John Swinbank made changes -
            Field Original Value New Value
            Epic Link DM-8306 [ 27828 ]
            swinbank John Swinbank made changes -
            Link This issue is triggered by DM-9862 [ DM-9862 ]
            swinbank John Swinbank made changes -
            Sprint DRP S17-5 [ 364 ]
            Team Data Release Production [ 10301 ]
            Labels hsc
            swinbank John Swinbank made changes -
            Assignee Bob Armstrong [ rearmstr ]
            swinbank John Swinbank made changes -
            Component/s meas_mosaic [ 10742 ]
            Story Points 2
            lauren Lauren MacArthur added a comment -

            Bob Armstrong, I never got to fully test it, and I may be misinterpreting the current issue, but this commit was intended to do what I believe you have described.

            rearmstr Bob Armstrong added a comment -

            Yeah, I probably didn't word it correctly. It is the same issue, but after testing I found a couple of things that weren't quite right. The wcs needed to be rotated back to the LSST system and you were rotating the image to apply the correction while I rotated the correction to apply the image.

            hchiang2 Hsin-Fang Chiang made changes -
            Link This issue blocks DM-10129 [ DM-10129 ]
            jbosch Jim Bosch made changes -
            Link This issue blocks DM-10266 [ DM-10266 ]
            jbosch Jim Bosch added a comment -

            Bob Armstrong, I've rebased this on LSST master as u/jbosch/DM-10236. Your changes look fine to me, so if my rebase of your changes looks fine to you (there were some conflicts), please go ahead and merge.

            jbosch Jim Bosch made changes -
            Status To Do [ 10001 ] Reviewed [ 10101 ]
            rearmstr Bob Armstrong added a comment -

            Merged.

            rearmstr Bob Armstrong made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]

              People

              • Assignee:
                rearmstr Bob Armstrong
                Reporter:
                rearmstr Bob Armstrong
                Watchers:
                Bob Armstrong, Jim Bosch, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel