The project has some standards about shadowing builtins like "filter." Unfortunately for you, I fall in the camp that really doesn't like shadowing "filter". I liked your original filterName/filter_name variable name. It differentiates it from a integer filterId too.
tests/testDcrTemplate.py lines 118 and 119: do you mean to leave this comment and line in? It's in a test, so I don't necessarily mind if you did.
Commits could be squashed into a few.
I assume these are eventually going to become Tasks and be renamed again?