Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-1059

track down difference in SdssShape implementation

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_base
    • Labels:

      Description

      The meas_base version of SdssShape produces slightly different outputs from the original version in meas_algorithms, but these should be identical. We should understand this difference rather than assume its benign just because it's small.

        Attachments

          Activity

          pgee Perry Gee added a comment -

          I didn't really make any changes on this ticket. However, while working on it, I fixed a couple of problems in meas_base. The only one of substance was a failure in one place to set the result object on failure. This is the change which ended up in DM-1067 by accident.

          As far as this issue is concerned, the slight differences in SdssShape are coming from a slight difference in SdssCentroid, and that ultimately from a very small difference in the convolution image being produced by the Psf. This is still a puzzle, but I was not able to go further without a more substantial amount of time.

          So there are essentially no changes for this ticket, except what Paul has already reviewed with 1067.

          pgee Perry Gee added a comment -

          The difference in the Psf models almost certainly caused by the difference in the PsfFlux algorithm which Jim introduced with his first plugin. But I have not successfully tracked the difference down to root causes. Not however that the PsfFlux and SdssCentroid for the icSrc tables differ very slightly


            People

            Assignee:
            pgee Perry Gee
            Reporter:
            jbosch Jim Bosch
            Reviewers:
            Jim Bosch
            Watchers:
            Jim Bosch, Perry Gee
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Jenkins

                No builds found.