Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11026

Remove use of PsfAttributes from image subtraction tasks

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ip_diffim, pipe_tasks
    • Labels:
      None

      Description

      PsfAttributes were deprecated and replaced with Psf class methods. This ticket is limited to instances in python (excluding the unit test in meas_algorithms), and including the unmaintained datarel and testing_pipeQA because they're both under "lsst" and I do not want instances of PsfAttributes showing up when I grep the stack.

      Triggered by: https://community.lsst.org/t/psf-matching-of-exposuref-image-cutouts-problem-with-xy0/2010

        Attachments

          Issue Links

            Activity

            yusra Yusra AlSayyad added a comment -

            Notes on checking that computeShape() returns the right answer:
            https://paper.dropbox.com/doc/Replacing-PsfAttributes-DM-11026-R09r9Tzn6Q2uSi6BD8lrQ

            reiss David Reiss added a comment -

            Changes all look fine. Please just make sure all unit tests pass with these changes – not sure how much they'll affect unit test results. Also that the examples still run.

            yusra Yusra AlSayyad added a comment -

            Jenkins run: https://ci.lsst.codes/job/stack-os-matrix/24791

            examples/runSubtractExposures.py didn't run before this change. I usually point people to the more recent examples/imagePsfMatchTask.py instead. (I'd actually like to delete examples/runSubtractExposures.py as a duplicate of examples/imagePsfMatchTask.py) Unless we get the ip_diffim/examples under ci, they'll keep getting out of date. I added a commit for some minimal cleanup to runSubtractExposures, to get it in working order. Will you take a look at that commit: https://github.com/lsst/ip_diffim/pull/67/commits/bb59e61c0217e9da68e43e562ec25eba22c28ea8

            reiss David Reiss added a comment -

            Looks good to me. I see that your edits actually fixed runSubtractExposures.py, so I'd prefer that you leave it around, for now. I think it's good to have examples that use both "fake" images (imagePsfMatchTask.py) and real ones. Perhaps we can eventually merge the two, and we will definitely consider using them if/when we get an ip_diffim CI going.


              People

              • Assignee:
                yusra Yusra AlSayyad
                Reporter:
                yusra Yusra AlSayyad
                Reviewers:
                David Reiss
                Watchers:
                David Reiss, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel