Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11225

git-lfs on lsst-dev with eups is missing an instruction

    Details

      Description

      git-lfs is provided as an eups package on the shared stack, but if one follows the instructions at https://developer.lsst.io/tools/git_lfs.html after typing setup git_lfs everything will appear to be correct, but it won't work.

      The solution is to either type git lfs install despite the fact it's already installed, or add

      [filter "lfs"]
      	clean = git-lfs clean -- %f
      	smudge = git-lfs smudge -- %f
      	process = git-lfs filter-process
      	required = true
      

      to their ~/.gitconfig file (which the instructions already have people editing).

      Someone should update the docs so other don't fall into this trap. It's a trivial fix, but I don't know how to edit the docs.

        Attachments

          Container Issues

            Activity

              People

              • Assignee:
                jsick Jonathan Sick
                Reporter:
                mfisherlevine Merlin Fisher-Levine
                Reviewers:
                John Swinbank
                Watchers:
                John Swinbank, Jonathan Sick, Merlin Fisher-Levine
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel