Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11307

Enable usage of NumPy 1.7 API with ndarray in pybind11 modules

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Templates:
    • Story Points:
      1
    • Team:
      Data Release Production

      Description

      DM-3705 brings the ndarray NumPy API up to level 1.7. This allows us to suppress the warnings about it by forcing that API level to be used. Unfortunately, that requires sticking #define NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION at the top of every module that uses ndarray.

      Find some way to do this and do it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pschella Pim Schellart [X] (Inactive)
                Watchers:
                Jim Bosch, Krzysztof Findeisen, Pim Schellart [X] (Inactive), Russell Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel