Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11334

Update documenteer dependency for lsst-texmf, developer.lsst.io sites, and technotes

    Details

      Description

      Pin documenteer >0.1,<0.2 in these projects to preserve existing assumptions about dependencies.

      For technotes, the right approach might be to update to documenteer 0.2 and make the necessary changes to their conf.py files.

        Attachments

          Issue Links

            Activity

            Hide
            jsick Jonathan Sick added a comment -

            I've upgraded all DMTN, SQR, and SMTN technotes to use the current version of documenteer and updated their Makefiles to include the new refresh-bib command. I've also moved very early SQR, DMTN, and SMTN technotes from Read the Docs to LSST the Docs.

            Show
            jsick Jonathan Sick added a comment - I've upgraded all DMTN, SQR, and SMTN technotes to use the current version of documenteer and updated their Makefiles to include the new refresh-bib command. I've also moved very early SQR, DMTN, and SMTN technotes from Read the Docs to LSST the Docs.

              People

              • Assignee:
                jsick Jonathan Sick
                Reporter:
                jsick Jonathan Sick
                Watchers:
                Jonathan Sick
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel