Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11641

Integration tests of squash-db, squash-api, squash-bokeh, squash-dash

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The minimum requirement is to have squash-db, squash-api and squash-bokeh working together before moving on.

      There's still a bug during integration tests:

      File "/usr/local/lib/python3.6/site-packages/requests/adapters.py", line 508, in send
          raise ConnectionError(e, request=request)
      requests.exceptions.ConnectionError: HTTPSConnectionPool(host='squash-local.lsst.codes', port=30899): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f102ee90898>: Failed to establish a new connection: [Errno -2] Name or service not known',))
       
      2017-08-23 15:53:40,677 200 GET /AMx (172.17.0.1) 8.13ms
      

        Attachments

          Issue Links

            Activity

            afausti Angelo Fausti added a comment - - edited
            • Added monitor and measurements endpoints to the squash-api to return data for the Monitor app as pandas data frame, for efficiency.
            afausti Angelo Fausti added a comment -
            • Added filters by metric and ci_dataset in the squash-api now we reload the data if either the metric or the dataset change.
            afausti Angelo Fausti added a comment -
            • Refactoring of the Monitor app after changes in the squash-api
            afausti Angelo Fausti added a comment - - edited
            • Monitor app is working again after refactoring. An important improvement regarding performance is that now we have separate endpoints to return data for measurements and code_changes in the API. measurements data changes each time we change a metric or ci_dataset while code_changes data is fixed. Since the API results are cached we don't need to (re)compute and (re)load the code_changes data each time, we just merge the measurements and code_changes pandas data frames using the ci_id as index in order to display the code changes associated to the the actual set of measurements.
            afausti Angelo Fausti added a comment -

            Closing this ticket. As a result of the integration tests of the squash microservices we

            this was tested locally with minikube, however as described in DM-11901 we decided to postpone the support to local deployment with minikube in favor of the production deployment.


              People

              Assignee:
              afausti Angelo Fausti
              Reporter:
              afausti Angelo Fausti
              Watchers:
              Angelo Fausti
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.