Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11681

update-cmirror job creating files with bad ownersihp

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Description

      Files created on the docker volume mount should have ownership of jenkins-slave:jenkins-slave rather than centos:centos.

      [root@jenkins-el7-4 infrastructure]# ls -la /home/jenkins-slave/workspace/sqre/infrastructure/update-cmirror/local_mirror/linux-64/_license-1.1-py27_0.tar.bz2
      -rw-r--r-- 1 centos centos 195012 Jun 14 05:26 /home/jenkins-slave/workspace/sqre/infrastructure/update-cmirror/local_mirror/linux-64/_license-1.1-py27_0.tar.bz2
      
      

        Attachments

          Issue Links

            Activity

            jhoblitt Joshua Hoblitt added a comment -

            It appears that the file ownership was correctly fixed in DM-11161. The errors were caused by an old workdir on el7-4 that had bad ownership.

            jhoblitt Joshua Hoblitt added a comment -

            The workspace permissions were manually fixed up on el7-4. The PR attached to the issue is a minor consistency cleanup of the jenkins jobs I noticed while investigating this failure.


              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                Joshua Hoblitt
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel