Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11765

Update pybind11 wrappers to use PYBIND11_MODULE instead of init

    XMLWordPrintable

Details

    • Story
    • Status: Invalid
    • Resolution: Done
    • None
    • None
    • None
    • 1
    • Data Release Production

    Description

      With pybind11 version 2.2.0 PYBIND11_PLUGIN and the corresponding pybind11_init are deprecated and raise lots of warnings at compile time.

      warning: 'pybind11_init' is deprecated: PYBIND11_PLUGIN is deprecated, use PYBIND11_MODULE

      Update all modules to use the new macro.

      Attachments

        Issue Links

          Activity

            Now blocks DM-11695, because we don't want code to suddenly display deprecation warnings all over the place.

            pschella Pim Schellart [X] (Inactive) added a comment - Now blocks DM-11695 , because we don't want code to suddenly display deprecation warnings all over the place.
            tjenness Tim Jenness added a comment -

            This was mostly done in DM-14828.

            tjenness Tim Jenness added a comment - This was mostly done in DM-14828 .

            People

              Unassigned Unassigned
              pschella Pim Schellart [X] (Inactive)
              Pim Schellart [X] (Inactive), Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.