Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11800

Update meas_mosaic to new transform-based API for afw::cameraGeom

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_mosaic
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      DRP F17-4
    • Team:
      Data Release Production

      Description

      With the merge of DM-5922, meas_mosaic is currently broken with errors like:

      src/mosaicfit.cc:2500:38: error: 'lsst::afw::cameraGeom::CameraTransformMap' has not been declared
                           afw::cameraGeom::CameraTransformMap::Transforms newTr;
                                            ^
      

      Please update meas_mosaic to the new afw::cameraGeom API.

        Attachments

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment - - edited

            Would you mind giving this a look? I can confirm identical meas_mosaic results for w_2017_34 + meas_mosaic:master and w_2017_35 + meas_mosaic:tickets/DM-11800

            An lsst_distrib + meas_mosaic:tickets/DM-11800 Jenkins is running (see also)

            rowen Russell Owen added a comment -

            This looks perfect. Thank you for testing the new code against the old (important because meas_mosaic has few unit tests).

            lauren Lauren MacArthur added a comment -

            Thanks Russell. Merged to master.


              People

              Assignee:
              lauren Lauren MacArthur
              Reporter:
              lauren Lauren MacArthur
              Reviewers:
              Russell Owen
              Watchers:
              Hsin-Fang Chiang, John Swinbank, Krzysztof Findeisen, Lauren MacArthur, Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.