Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11849

setup test env for DM-11727

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Attachments

        Issue Links

          Activity

          Hide
          jhoblitt Joshua Hoblitt added a comment -

          There was a problem with the jenkins job that updates the conda package and miniconda mirror. There `aws s3 sync` job for the conda package was error as it was unable to delete objection (intentionally does not have permissions to do so) which was causing the job to fail before the `sync` of the miniconda installers.

          Show
          jhoblitt Joshua Hoblitt added a comment - There was a problem with the jenkins job that updates the conda package and miniconda mirror. There `aws s3 sync` job for the conda package was error as it was unable to delete objection (intentionally does not have permissions to do so) which was causing the job to fail before the `sync` of the miniconda installers.
          Hide
          jhoblitt Joshua Hoblitt added a comment -

          Several newer releases of conda-mirror have been cut, which include my requested parallel verification feature:

          https://github.com/maxpoint/conda-mirror/issues/43

          Show
          jhoblitt Joshua Hoblitt added a comment - Several newer releases of conda-mirror have been cut, which include my requested parallel verification feature: https://github.com/maxpoint/conda-mirror/issues/43
          Hide
          jhoblitt Joshua Hoblitt added a comment -

          I've updated the version of conda-mirror and enabled the new concurrent validation with the --num-threads option.

          Show
          jhoblitt Joshua Hoblitt added a comment - I've updated the version of conda-mirror and enabled the new concurrent validation with the --num-threads option.
          Hide
          jhoblitt Joshua Hoblitt added a comment - - edited

          The updated conda matplotlib package depends on qt, which in turn needs libGL.so.1. This has been added to puppet-lsststack. In addition, the version of cmake on el7 was pinned to avoid needing to install a newer version via conda.

          Show
          jhoblitt Joshua Hoblitt added a comment - - edited The updated conda matplotlib package depends on qt , which in turn needs libGL.so.1 . This has been added to puppet-lsststack . In addition, the version of cmake on el7 was pinned to avoid needing to install a newer version via conda.
          Hide
          jhoblitt Joshua Hoblitt added a comment -

          All changes in support of DM-11727 have been pushed to production.

          Show
          jhoblitt Joshua Hoblitt added a comment - All changes in support of DM-11727 have been pushed to production.

            People

            • Assignee:
              jhoblitt Joshua Hoblitt
              Reporter:
              jhoblitt Joshua Hoblitt
              Watchers:
              Joshua Hoblitt, Tim Jenness
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel