Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11974

Add calibUsed-only qa plots to CoaddAnalysis

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • pipe_analysis
    • None
    • 1
    • DRP S19-3
    • Data Release Production

    Description

      Add plots similar to the visit-level calibUsed-only versions added in DM-11322 but at the coadd level. This cannot be done until the flags are propagated to the coadd catalogs when DM-11866 lands.

      Attachments

        Issue Links

          Activity

            I will also use this ticket to update the import of TractDataIdContainer which was previously being importing from lsst.coadd.utils. However, this version was deleted in DM-17433 as it was essentially a duplicate of its namesake in lsst.pipe.drivers.utils. Thus, we must now import and use the TractDataIdContainer located in lsst.pipe.drivers.utils.

            lauren Lauren MacArthur added a comment - I will also use this ticket to update the import of  TractDataIdContainer which was previously being importing from  lsst.coadd.utils . However, this version was deleted in DM-17433 as it was essentially a duplicate of its namesake in lsst.pipe.drivers.utils. Thus, we must now import and use the TractDataIdContainer located in lsst.pipe.drivers.utils .

            Would you mind giving this a look?  The TractDataIdContainer import un-breaks us following DM-17433.  The column copying now allows for the following calib-used plots to be created (in addition to those already being create for calib_psf_used for the coadds:

            plot-t9697-HSC-I-matches_dec_calib_astrometry_used-psfMagHist.png
            plot-t9697-HSC-I-matches_dec_calib_astrometry_used-sky-gals.png
            plot-t9697-HSC-I-matches_dec_calib_astrometry_used-sky-stars.png
            plot-t9697-HSC-I-matches_distance_calib_astrometry_used-psfMagHist.png
            plot-t9697-HSC-I-matches_distance_calib_astrometry_used-sky-gals.png
            plot-t9697-HSC-I-matches_distance_calib_astrometry_used-sky-stars.png
            plot-t9697-HSC-I-matches_mag_calib_photometry_used-psfMagHist.png
            plot-t9697-HSC-I-matches_mag_calib_photometry_used-sky-stars.png
            plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-psfMagHist.png
            plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-sky-gals.png
            plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-sky-stars.png
            plot-t9697-HSC-I-matches_ra_calib_astrometry_used-psfMagHist.png
            plot-t9697-HSC-I-matches_ra_calib_astrometry_used-sky-gals.png
            plot-t9697-HSC-I-matches_ra_calib_astrometry_used-sky-stars.png
            

            You can see examples at this link which was run using:

            coaddAnalysis.py /datasets/hsc/repo --rerun=RC/w_2019_06/DM-17400:private/lauren/DM-11974 -c doWriteParquetTables=False --id filter=HSC-I tract=9697 patch=4,5^5,5^4,4^5,4
            

            PR: https://github.com/lsst-dm/pipe_analysis/pull/28

            lauren Lauren MacArthur added a comment - Would you mind giving this a look?  The TractDataIdContainer import un-breaks us following DM-17433 .  The column copying now allows for the following calib-used plots to be created (in addition to those already being create for calib_psf_used for the coadds: plot-t9697-HSC-I-matches_dec_calib_astrometry_used-psfMagHist.png plot-t9697-HSC-I-matches_dec_calib_astrometry_used-sky-gals.png plot-t9697-HSC-I-matches_dec_calib_astrometry_used-sky-stars.png plot-t9697-HSC-I-matches_distance_calib_astrometry_used-psfMagHist.png plot-t9697-HSC-I-matches_distance_calib_astrometry_used-sky-gals.png plot-t9697-HSC-I-matches_distance_calib_astrometry_used-sky-stars.png plot-t9697-HSC-I-matches_mag_calib_photometry_used-psfMagHist.png plot-t9697-HSC-I-matches_mag_calib_photometry_used-sky-stars.png plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-psfMagHist.png plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-sky-gals.png plot-t9697-HSC-I-matches_raCosDec_calib_astrometry_used-sky-stars.png plot-t9697-HSC-I-matches_ra_calib_astrometry_used-psfMagHist.png plot-t9697-HSC-I-matches_ra_calib_astrometry_used-sky-gals.png plot-t9697-HSC-I-matches_ra_calib_astrometry_used-sky-stars.png You can see examples at this link which was run using: coaddAnalysis.py /datasets/hsc/repo --rerun=RC/w_2019_06/DM-17400:private/lauren/DM-11974 -c doWriteParquetTables=False --id filter=HSC-I tract=9697 patch=4,5^5,5^4,4^5,4 PR: https://github.com/lsst-dm/pipe_analysis/pull/28

            Looks like two more files (ups/pipe_analysis.table and python/lsst/pipe/analysis/colorAnalysis.py) need this update too.
            Otherwise looks good to me!

            hchiang2 Hsin-Fang Chiang added a comment - Looks like two more files ( ups/pipe_analysis.table and python/lsst/pipe/analysis/colorAnalysis.py ) need this update too. Otherwise looks good to me!

            Thanks a million for the speedy and thorough review!  Both changes made.  Merged to master.

            lauren Lauren MacArthur added a comment - Thanks a million for the speedy and thorough review!  Both changes made.  Merged to master.

            People

              lauren Lauren MacArthur
              lauren Lauren MacArthur
              Hsin-Fang Chiang
              Hsin-Fang Chiang, Lauren MacArthur
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.