Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-11988

nightly-release d_2017_09_22 failed

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Description

      The d_2017_09_22 nightly-release failed building the docker.io/lsstsqre/centos:7-stack-lsst_distrib-... image.

      Reading configuration data from /opt/lsst/software/stack/stack/miniconda3-4.3.21-10a4fa6/ups_db/_servers_/https://eups.lsst.codes/stack/redhat/el7/gcc-system/miniconda3-4.2.12-7c8e67/config.txt
      Tag d_2017_09_22 not supported at https://eups.lsst.codes/stack/redhat/el7/gcc-system/miniconda3-4.2.12-7c8e67
      Tag d_2017_09_22 not supported at https://eups.lsst.codes/stack/redhat/el7/gcc-system/miniconda3-4.2.12-7c8e67
      eups distrib: Product lsst_distrib d_2017_09_22 not found in any package repository
      Removing lockfile /opt/lsst/software/stack/stack/miniconda3-4.3.21-10a4fa6/.lockDir/exclusive-lsst.17
      

      There are actually two problems here.

      1. https://github.com/lsst-sqre/docker-tarballs/blob/master/Dockerfile has a hardcoded EUPS_PKGROOT=https://eups.lsst.codes/stack/redhat/el7/gcc-system/miniconda3-4.2.12-7c8e67, which is no longer the latest env.
      1. No tarballs for miniconda3-4.2.12-7c8e67 were built, likely caused by this commit https://github.com/lsst-sqre/jenkins-dm-jobs/commit/0d34bcf75e09a4827eecebce35ce21aa34df66d7

        Attachments

          Activity

          jhoblitt Joshua Hoblitt added a comment -

          I've manually walked through the "stack" image build and the jupyerlabdemo image build. The tarball build for OSX is still running – once that completes I'm going to rerun the entire pipeline to make sure it makes it through without intervention.


            People

            • Assignee:
              jhoblitt Joshua Hoblitt
              Reporter:
              jhoblitt Joshua Hoblitt
              Watchers:
              Adam Thornton, Joshua Hoblitt, Tim Jenness
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel