Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12017

Write a function to apply PhotoCalib results to a catalog

    Details

    • Team:
      Data Release Production

      Description

      Currently, meas_mosaic uses its own persistence format for its calculations of new catalog values, etc. From DM-10007, meas_mosaic now persists an afw.image.PhotoCalib containing the same model. We should switch to using that persistence format for the catalog updates, to make the switch to jointcal more trivial.

      Once done, we can more reliably confirm that the changes in DM-11905 did not affect meas_mosaic's PhotoCalib persistence by regenerating the files in the tests/data// directory (I had manually hacked them to work for the ticket itself) and re-running tests/test_FluxFitBoundedField.py.

        Attachments

          Issue Links

            Activity

            Parejkoj John Parejko added a comment -

            If the idea is for this to work on catalogs, then that's exactly DM-10155, and it lives in PhotoCalib itself.

            jbosch Jim Bosch added a comment - - edited

            Yes, more-or-less; in our discussion earlier today we thought those two existing methods were already implemented and we just needed to write some Python code to do something like the countsToFluxAndMagnitude also mentioned as a possibility for DM-10155.

            Parejkoj John Parejko added a comment - - edited

            The methods described in DM-10155 are not implemented because until recently there was no place to put the calibrated fluxes and magnitudes. Now that RFC-322 is done, I can implement them (or probably remove them and do the one that does both). If this ticket was intended to apply to only catalogs (with DM-15751 being the ticket for exposures), then I think it's just a dup of DM-10155.

            jbosch Jim Bosch added a comment -

            Yes, if we define DM-10155 as definitely including countsToFluxAndMagnitude.  If you agree, feel free to close this as a dup.

            Parejkoj John Parejko added a comment -

            Closed as duplicate of DM-10155


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                Parejkoj John Parejko
                Watchers:
                Jim Bosch, John Parejko, John Swinbank, Lauren MacArthur, Paul Price
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel