Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12255

science-pipelines/lsst_distrib failing -- null branch

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Description

      It appears that a groovy null may be getting stringified as the string "null".

       
                  treecorr:  ok (0.3 sec).
                ci_ctio0m9:  ok (62.5 sec).
      Traceback (most recent call last):
        File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/lsst_build/bin/lsst-build", line 51, in <module>
          args.func(args)
        File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/lsst_build/python/lsst/ci/prepare.py", line 785, in run
          manifest = p.construct(args.products)
        File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/lsst_build/python/lsst/ci/prepare.py", line 749, in construct
          self.product_fetcher.validate_refs()
        File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/lsst_build/python/lsst/ci/prepare.py", line 373, in validate_refs
          " {}".format(",".join(missed)))
      RuntimeError: Did not checkout any products with the following refs: null
      Failed during rebuild of DM stack.
      
      

        Attachments

          Activity

          jhoblitt Joshua Hoblitt added a comment -

          It appears that the problem is in the job-dsl side, these are the env vars that are being generated:

          PRODUCT=lsst_distrib ci_hsc
          BRANCH=null
          SKIP_DEMO=false
          SKIP_DOCS=false
          

          jhoblitt Joshua Hoblitt added a comment -

          A fix has been merged to production.

          jhoblitt Joshua Hoblitt added a comment -

          This appears to be well resolved.


            People

            • Assignee:
              jhoblitt Joshua Hoblitt
              Reporter:
              jhoblitt Joshua Hoblitt
              Reviewers:
              Joshua Hoblitt
              Watchers:
              Joshua Hoblitt
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel