Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12520

FitSipDistortionTask needs tests and has an assertion error

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_astrom
    • Labels:
      None
    • Team:
      Data Release Production

      Description

      FitSipDistortionTask has no unit tests. Since it is intended as a drop-in replacement for FitTanSipWcsTask it should be trivial to copy existing tests of FitTanSipWcsTask and use FitSipDistortionTask instead.

      I tried this with test_fitTanSipWcsTask.py and found a serious issue:

       Assertion failed: (static_cast<std::size_t>(nGood + nClip) == _data.size()), function rejectOutliers, file src/ScaledPolynomialTransformFitter.cc, line 470.
      

      Also FitTanSipWcsConfig has a field numIter and FitSipDistortionConfig does not.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -

            I think this is the same as a problem Paul Price saw when running on some HSC data; I thought we ticketed that but I can't find it now. If it is the same thing, it's definitely a blocker for actually using this as the default.

            swinbank John Swinbank added a comment -

            Looks like a duplicate of DM-11103, so I'm closing as such: if you disagree, please reopen.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rowen Russell Owen
              Watchers:
              Jim Bosch, John Swinbank, Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins Builds

                  No builds found.