Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12522

Incorporate new color terms

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_subaru
    • Labels:
    • Team:
      External

      Description

      Masayuki Tanaka has calculated some new color terms using the restricted color ranges (DM-12207). These should replace the current ones.

        Attachments

          Issue Links

            Activity

            price Paul Price added a comment -

            'g': Colorterm(primary="g", secondary="r",c0=0.005905, c1=0.063651, c2=-0.000716),
            'r': Colorterm(primary="r", secondary="i",c0=-0.000294, c1=-0.005458, c2=-0.009451),
            'r2': Colorterm(primary="r", secondary="i",c0=0.000118, c1=-0.002790, c2=-0.014363),
            'i': Colorterm(primary="i", secondary="z",c0=0.000979, c1=-0.154608, c2=-0.010429),
            'i2': Colorterm(primary="i", secondary="z",c0=0.001653, c1=-0.206313, c2=-0.016085),
            'z': Colorterm(primary="z", secondary="y",c0=-0.005585, c1=-0.220704, c2=-0.298211),
            'y': Colorterm(primary="y", secondary="z",c0=-0.001952, c1=0.199570, c2=0.216821),
            'I945': Colorterm(primary="y", secondary="z",c0=0.005275, c1=-0.194285, c2=-0.125424),
            'N387': Colorterm(primary="g", secondary="r",c0=0.427879, c1=1.869068, c2=0.540580),
            'N468': Colorterm(primary="g", secondary="r",c0=-0.042240, c1=0.121756, c2=0.027599),
            'N515': Colorterm(primary="g", secondary="r",c0=-0.021913, c1=-0.253159, c2=0.151553),
            'N527': Colorterm(primary="g", secondary="r",c0=-0.020641, c1=-0.366167, c2=0.038497),
            'N656': Colorterm(primary="r", secondary="i",c0=0.035658, c1=-0.512071, c2=0.042824),
            'N718': Colorterm(primary="i", secondary="r",c0=-0.016294, c1=-0.233139, c2=0.252505),
            'N816': Colorterm(primary="i", secondary="z",c0=0.013806, c1=-0.717681, c2=0.049289),
            'N921': Colorterm(primary="z", secondary="y",c0=0.002039, c1=-0.477412, c2=-0.492151),
            'N973': Colorterm(primary="y", secondary="z",c0=-0.007775, c1=-0.050972, c2=-0.197278),
            

            price Paul Price added a comment -

            Jenkins passed.

            price Paul Price added a comment -

            Lauren MacArthur, would you run your eye over these very simple changes please?

            price@pap-laptop:~/LSST/obs_subaru (tickets/DM-12522=) $ git sub-patch
            commit e17d805a2f547ba722547a4c15de4df82d48ce45 (HEAD -> tickets/DM-12522, origin/tickets/DM-12522)
            Author: Paul Price <price@astro.princeton.edu>
            Date:   Tue Nov 7 10:07:58 2017 +0800
             
                config: update color terms for HSC
                
                Since we're now restricting the color range of sources used in photoCal,
                the color terms have changed slightly. These values were calculated by
                Masayuki Tanaka, supplied in e-mail ([Hsc_software 6029] Re: color terms).
             
            diff --git a/config/hsc/colorterms.py b/config/hsc/colorterms.py
            index d64c4f4..7d7dbe4 100644
            --- a/config/hsc/colorterms.py
            +++ b/config/hsc/colorterms.py
            @@ -22,17 +22,22 @@ config.data = {
                     'N921': Colorterm(primary="z", secondary="i", c0=0.00752972, c1=0.09863530, c2=-0.05451118),
                 }),
                 "ps1*": ColortermDict(data={
            -        'g': Colorterm(primary="g", secondary="r", c0=0.00730066, c1=0.06508481, c2=-0.01510570),
            -        'r': Colorterm(primary="r", secondary="i", c0=0.00279757, c1=0.02093734, c2=-0.01877566),
            -        'r2': Colorterm(primary="r", secondary="i", c0=0.00117690, c1=0.00003996, c2=-0.01667794),
            -        'i': Colorterm(primary="i", secondary="z", c0=0.00166891, c1=-0.13944659, c2=-0.03034094),
            -        'i2': Colorterm(primary="i", secondary="z", c0=0.00180361, c1=-0.18483562, c2=-0.02675511),
            -        'z': Colorterm(primary="z", secondary="y", c0=-0.00907517, c1=-0.28840221, c2=-0.00316369),
            -        'y': Colorterm(primary="y", secondary="z", c0=-0.00156858, c1=0.14747401, c2=0.02880125),
            -        'N387': Colorterm(primary="g", secondary="r", c0=0.54993211, c1=1.93524093, c2=0.33520994),
            -        'N718': Colorterm(primary="i", secondary="r", c0=-0.03742158, c1=-0.29362076, c2=0.19006956),
            -        'N816': Colorterm(primary="i", secondary="z", c0=0.01191062, c1=-0.68757034, c2=-0.10781564),
            -        'N921': Colorterm(primary="z", secondary="y", c0=0.00142051, c1=-0.59278367, c2=-0.25059679),
            -        'N973': Colorterm(primary="y", secondary="z", c0=-0.00640165, c1=-0.03915281, c2=-0.24088565),
            +        'g': Colorterm(primary="g", secondary="r", c0=0.005905, c1=0.063651, c2=-0.000716),
            +        'r': Colorterm(primary="r", secondary="i", c0=-0.000294, c1=-0.005458, c2=-0.009451),
            +        'r2': Colorterm(primary="r", secondary="i", c0=0.000118, c1=-0.002790, c2=-0.014363),
            +        'i': Colorterm(primary="i", secondary="z", c0=0.000979, c1=-0.154608, c2=-0.010429),
            +        'i2': Colorterm(primary="i", secondary="z", c0=0.001653, c1=-0.206313, c2=-0.016085),
            +        'z': Colorterm(primary="z", secondary="y", c0=-0.005585, c1=-0.220704, c2=-0.298211),
            +        'y': Colorterm(primary="y", secondary="z", c0=-0.001952, c1=0.199570, c2=0.216821),
            +        'I945': Colorterm(primary="y", secondary="z", c0=0.005275, c1=-0.194285, c2=-0.125424),
            +        'N387': Colorterm(primary="g", secondary="r", c0=0.427879, c1=1.869068, c2=0.540580),
            +        'N468': Colorterm(primary="g", secondary="r", c0=-0.042240, c1=0.121756, c2=0.027599),
            +        'N515': Colorterm(primary="g", secondary="r", c0=-0.021913, c1=-0.253159, c2=0.151553),
            +        'N527': Colorterm(primary="g", secondary="r", c0=-0.020641, c1=-0.366167, c2=0.038497),
            +        'N656': Colorterm(primary="r", secondary="i", c0=0.035658, c1=-0.512071, c2=0.042824),
            +        'N718': Colorterm(primary="i", secondary="r", c0=-0.016294, c1=-0.233139, c2=0.252505),
            +        'N816': Colorterm(primary="i", secondary="z", c0=0.013806, c1=-0.717681, c2=0.049289),
            +        'N921': Colorterm(primary="z", secondary="y", c0=0.002039, c1=-0.477412, c2=-0.492151),
            +        'N973': Colorterm(primary="y", secondary="z", c0=-0.007775, c1=-0.050972, c2=-0.197278),
                 }),
             }
            

            lauren Lauren MacArthur added a comment -

            I can confirm that the numbers match those provided by Masayuki Tanaka. You may want to note in the commit message (as he did in e-mail [Hsc_software 6029] Re: color terms) that "These are from the Pickles library, but the numbers from BPGS [Bruzual-Persson-Gunn-Stryker library] are similar."

            price Paul Price added a comment -

            Thanks Lauren.

            Updated the commit message and merged to master.


              People

              • Assignee:
                price Paul Price
                Reporter:
                price Paul Price
                Reviewers:
                Lauren MacArthur
                Watchers:
                Lauren MacArthur, Paul Price
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel