Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12561

jupyterlabdemo build failing

    Details

      Description

      > npm pack @jupyter-widgets/jupyterlab-manager
      jupyter-widgets-jupyterlab-manager-0.29.3.tgz
      Traceback (most recent call last):
        File "/usr/bin/jupyter-labextension", line 11, in <module>
          load_entry_point('jupyterlab==0.29.0rc0', 'console_scripts', 'jupyter-labextension')()
        File "/usr/lib/python3.4/site-packages/jupyter_core/application.py", line 266, in launch_instance
          return super(JupyterApp, cls).launch_instance(argv=argv, **kwargs)
        File "/usr/lib/python3.4/site-packages/traitlets/config/application.py", line 658, in launch_instance
          app.start()
        File "/usr/lib/python3.4/site-packages/jupyterlab/labextensions.py", line 174, in start
          super(LabExtensionApp, self).start()
        File "/usr/lib/python3.4/site-packages/jupyter_core/application.py", line 255, in start
          self.subapp.start()
        File "/usr/lib/python3.4/site-packages/jupyterlab/labextensions.py", line 64, in start
          for arg in self.extra_args]
        File "/usr/lib/python3.4/site-packages/jupyterlab/labextensions.py", line 64, in <listcomp>
          for arg in self.extra_args]
        File "/usr/lib/python3.4/site-packages/jupyterlab/commands.py", line 137, in install_extension
          return IOLoop.instance().run_sync(func)
        File "/usr/lib64/python3.4/site-packages/tornado/ioloop.py", line 458, in run_sync
          return future_cell[0].result()
        File "/usr/lib64/python3.4/site-packages/tornado/concurrent.py", line 238, in result
          raise_exc_info(self._exc_info)
        File "<string>", line 4, in raise_exc_info
        File "/usr/lib64/python3.4/site-packages/tornado/gen.py", line 1069, in run
          yielded = self.gen.send(value)
        File "/usr/lib/python3.4/site-packages/jupyterlab/commands.py", line 208, in install_extension_async
          raise ValueError(msg)
      ValueError: 
      "@jupyter-widgets/jupyterlab-manager@0.29.3" is not compatible with the current JupyterLab
      Conflicting Dependencies:
      JupyterLab              Extension            Package
      >=0.51.0-0 <0.52.0-0    >=0.50.2-0 <0.51.0-0 @jupyterlab/services
      >=0.12.0-0 <0.13.0-0    >=0.11.1-0 <0.12.0-0 @jupyterlab/application
      >=0.12.0-0 <0.13.0-0    >=0.11.1-0 <0.12.0-0 @jupyterlab/notebook
      >=0.12.0-0 <0.13.0-0    >=0.11.1-0 <0.12.0-0 @jupyterlab/rendermime
      >=0.12.0-0 <0.13.0-0    >=0.11.1-0 <0.12.0-0 @jupyterlab/coreutils
       
      The command '/bin/sh -c jupyter labextension install @jupyter-widgets/jupyterlab-manager' returned a non-zero code: 1
      Docker build failed.
      
      

        Attachments

          Issue Links

            Activity

            Hide
            athornton Adam Thornton added a comment -

            JL build failures will no longer fail the nightly build.

            This particular one was due to upstream package versions changing.

            Show
            athornton Adam Thornton added a comment - JL build failures will no longer fail the nightly build. This particular one was due to upstream package versions changing.

              People

              • Assignee:
                athornton Adam Thornton
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                Adam Thornton, Joshua Hoblitt
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel