Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-1284

rename meas_multifit to meas_modelfit, and add to lsst_apps

    Details

      Attachments

        Issue Links

          Activity

          Hide
          jbosch Jim Bosch added a comment -

          Ready for review:

          • I've forked LSST/DMS/meas_multifit.git to contrib/meas_modelfit.git, and (on branch u/jbosch/DM-1284) done a lot of regexp replacement to change the names of files, directories and namespaces. There are no other changes, so I don't actually think it's necessary to inspect these manually in detail.
          • I've added meas_modelfit to lsst_apps' dependencies on u/jbosch/DM-1284 of lsst_apps.

          After the review, I'll need help with the next two steps:

          • A gitolite admin will need to move the package from contrib to LSST/DMS, and delete meas_multifit from LSST/DMS to avoid future confusion.
          • A GitHub admin will need to rename the meas_multifit mirror there to modelfit.

          After that, I'll merge the u/jbosch/DM-1284 branches to master and close the issue.

          Show
          jbosch Jim Bosch added a comment - Ready for review: I've forked LSST/DMS/meas_multifit.git to contrib/meas_modelfit.git, and (on branch u/jbosch/ DM-1284 ) done a lot of regexp replacement to change the names of files, directories and namespaces. There are no other changes, so I don't actually think it's necessary to inspect these manually in detail. I've added meas_modelfit to lsst_apps' dependencies on u/jbosch/ DM-1284 of lsst_apps. After the review, I'll need help with the next two steps: A gitolite admin will need to move the package from contrib to LSST/DMS, and delete meas_multifit from LSST/DMS to avoid future confusion. A GitHub admin will need to rename the meas_multifit mirror there to modelfit. After that, I'll merge the u/jbosch/ DM-1284 branches to master and close the issue.
          Hide
          ktl Kian-Tat Lim added a comment -

          Should MeasureMultiTask and its config value usePreviousMultiFit be changed? Or is the comment that it has bitrotted in overview.dox sufficient? I presume that MultiModel is still an appropriate name.

          Looks fine otherwise. Let me know when you're ready for the gitolite moves.

          Show
          ktl Kian-Tat Lim added a comment - Should MeasureMultiTask and its config value usePreviousMultiFit be changed? Or is the comment that it has bitrotted in overview.dox sufficient? I presume that MultiModel is still an appropriate name. Looks fine otherwise. Let me know when you're ready for the gitolite moves.
          Hide
          jbosch Jim Bosch added a comment -

          Should MeasureMultiTask and its config value usePreviousMultiFit be changed?

          This and MeasureMulti are some of the few names in the package that actually do refer to the multifit procedure, so they should remain as they are.

          Please go ahead with the gitolite moves whenever convenient.

          Show
          jbosch Jim Bosch added a comment - Should MeasureMultiTask and its config value usePreviousMultiFit be changed? This and MeasureMulti are some of the few names in the package that actually do refer to the multifit procedure, so they should remain as they are. Please go ahead with the gitolite moves whenever convenient.
          Hide
          ktl Kian-Tat Lim added a comment -

          gitolite moves are done. I am hoping that the mirroring will take care of GitHub and will fix manually if not.

          Show
          ktl Kian-Tat Lim added a comment - gitolite moves are done. I am hoping that the mirroring will take care of GitHub and will fix manually if not.
          Hide
          ktl Kian-Tat Lim added a comment -

          You were right; I needed to rename on GitHub to keep the comments/PRs. I removed the mirror and renamed the repo. But I'm not sure the mirroring is working properly; I don't see u/jbosch/DM-1284... I'm wondering if the fork+rename on the gitolite side is messing with something.

          Show
          ktl Kian-Tat Lim added a comment - You were right; I needed to rename on GitHub to keep the comments/PRs. I removed the mirror and renamed the repo. But I'm not sure the mirroring is working properly; I don't see u/jbosch/ DM-1284 ... I'm wondering if the fork+rename on the gitolite side is messing with something.
          Hide
          ktl Kian-Tat Lim added a comment -

          Got it to mirror properly with some manual help; I think it would have caught up eventually but maybe not until the next modification to meas_modelfit.

          Show
          ktl Kian-Tat Lim added a comment - Got it to mirror properly with some manual help; I think it would have caught up eventually but maybe not until the next modification to meas_modelfit.
          Hide
          jbosch Jim Bosch added a comment -

          Thanks for the help! Everything is now merged.

          Show
          jbosch Jim Bosch added a comment - Thanks for the help! Everything is now merged.

            People

            • Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Reviewers:
              Kian-Tat Lim
              Watchers:
              Jim Bosch, Kian-Tat Lim
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel