Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-12869

builds of lsst_distrib fail with setuptools_scm errors

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: stack release
    • Labels:
      None

      Description

      For several days now, the "clean" build jenkins job science-pipelines/lsst_distrib, which also starts building from an empty workspace, has been failing with setuptools_scm errors under either python_execnet or pytest. Eg.

      https://ci.lsst.codes/blue/organizations/jenkins/science-pipelines%2Flsst_distrib/detail/lsst_distrib/64/pipeline/31

            python_execnet: 1.4.1+1 :::::  [2017-11-29T22:41:50.059461Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/miniconda/lib/python3.6/site-packages/setuptools/dist.py", line 471, in finalize_options
      :::::  [2017-11-29T22:41:50.059465Z]     ep.load()(self, ep.name, value)
      :::::  [2017-11-29T22:41:50.059468Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/integration.py", line 22, in version_keyword
      :::::  [2017-11-29T22:41:50.059476Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 119, in get_version
      :::::  [2017-11-29T22:41:50.059482Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 83, in _do_parse
      :::::  [2017-11-29T22:41:50.059487Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 31, in version_from_scm
      :::::  [2017-11-29T22:41:50.059490Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 36, in _version_from_entrypoint
      :::::  [2017-11-29T22:41:50.059494Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/git.py", line 116, in parse
      :::::  [2017-11-29T22:41:50.059497Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-6.py3/lsstsw/build/python_execnet/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/version.py", line 102, in meta
      :::::  [2017-11-29T22:41:50.059503Z] AssertionError: cant parse version None
      ERROR (1 sec).
      

                   pytest: 3.2.0+1 :::::  [2017-11-30T04:45:36.846221Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/miniconda/lib/python3.6/site-packages/setuptools/dist.py", line 471, in finalize_options
      :::::  [2017-11-30T04:45:36.846225Z]     ep.load()(self, ep.name, value)
      :::::  [2017-11-30T04:45:36.846228Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/integration.py", line 22, in version_keyword
      :::::  [2017-11-30T04:45:36.846232Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 119, in get_version
      :::::  [2017-11-30T04:45:36.846235Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 83, in _do_parse
      :::::  [2017-11-30T04:45:36.846239Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 31, in version_from_scm
      :::::  [2017-11-30T04:45:36.846243Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/__init__.py", line 36, in _version_from_entrypoint
      :::::  [2017-11-30T04:45:36.846246Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/git.py", line 116, in parse
      :::::  [2017-11-30T04:45:36.846250Z]   File "/home/jenkins-slave/workspace/science-pipelines/lsst_distrib/centos-7.py3/lsstsw/build/pytest/.eggs/setuptools_scm-1.15.6-py3.6.egg/setuptools_scm/version.py", line 102, in meta
      :::::  [2017-11-30T04:45:36.846253Z] AssertionError: cant parse version None
      ERROR (1 sec).
      

      Tim Jenness and I investigated the python_execnet failure yesterday and were unable to identify a code change in any of that package's dependencies.

        Attachments

          Issue Links

            Activity

            jhoblitt Joshua Hoblitt added a comment - - edited

            3:45 is the approximate build time of lsst_build. This problem is the result of unexpected side effects so I won't have confidence the problem is fixed until it actually builds.

            jhoblitt Joshua Hoblitt added a comment -

            Jira is finally online... The simple fix I was testing passed in one of my test envs and was merged to master. This is intended to be a short term kludge to unblock devs until a better solution can be tested.

            jhoblitt Joshua Hoblitt added a comment -

            Tim Jenness I'm not sure what to do with this issue... should I close it out or leave it open pending an eups release that enables a _build dir?

            tjenness Tim Jenness added a comment -

            Close it. I'll make a new ticket to fix things.

            jhoblitt Joshua Hoblitt added a comment -

            Summary: the setuptools_scm error has been kludged around to get master building again without having to remove the weekly tag from the 3rd party repos. A proper fix is underway on DM-13061 .


              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel