Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13088

Bring LDM-294 current; fix document build

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Management
    • Labels:
    • Team:
      Architecture

      Description

      There is a considerable amount of work on the draft and DM-7501 branches for LDM-294 that has been quiescent since October. It includes updates to management staffing, e.g., Simon's move to Tucson.

      There is also a apparent shortcoming of the Makefile for the document that means that the productlist.csv file is not used automatically to create all the required new .tex files as part of the build. In particular, this affects the component/product table in Appendix A.

      Finally, at the same time we should switch to the new conventions for release of change-controlled DM documents.

      There are also further changes that could/should be made to the document, but this ticket is just about bringing old in-process work to a conclusion.

        Attachments

          Issue Links

            Activity

            gpdf Gregory Dubois-Felsmann created issue -
            gpdf Gregory Dubois-Felsmann made changes -
            Field Original Value New Value
            Link This issue relates to DM-7501 [ DM-7501 ]
            womullan Wil O'Mullane added a comment -

            I merged the PR - I do not consider the inclusion of the product list processing as esential but l will see about adding it to the makefile

            womullan Wil O'Mullane added a comment -

            makefile also fixed now to remake product tree when productlist.csv changes

            gpdf Gregory Dubois-Felsmann added a comment -

            The tickets/DM-13088 branch doesn't seem to be being processed by LTD - it's not visible on https://ldm-294.lsst.io/v/index.html and https://ldm-294.lsst.io/v/DM-13088/index.html does not exist. Does that require some additional configuration to arrange? Jonathan Sick?

            swinbank John Swinbank added a comment -

            It's being processed, it's just broken: https://travis-ci.org/lsst/LDM-294/builds/319973692

            swinbank John Swinbank added a comment - - edited

            I fixed the most egregious errors, but the build still fails. I think it's because the lsstsqre/lsst-texmf Docket container is over-riding the version of Python being used: see the log here and note that we start by installing Python 3.5, but by the time the build is executing the default Python is 2.7.6. I'm not going to try to understand what the container is doing at this time on a Friday night!

            The document is quite straightforward to build on a laptop, though; if you need a PDF, let me know and I'll make one for you.

            jsick Jonathan Sick made changes -
            Link This issue relates to DM-13140 [ DM-13140 ]
            jsick Jonathan Sick added a comment -

            In DM-13140 I've fixed many of the issues (in particular, by splitting the build across the native Travis VM for the python steps and running Docker only for the LaTeX related steps).

            gpdf Gregory Dubois-Felsmann made changes -
            Link This issue is parent task of DM-13165 [ DM-13165 ]
            womullan Wil O'Mullane added a comment -

            I merged DM-13140 thanks. I also made other fixes .. now lets see what travis makes of it

            womullan Wil O'Mullane added a comment -

            Travis is happy - I think all issues are fixed - this could be closed (but I see its assigned to John Swinbank)

            swinbank John Swinbank added a comment -

            I also think this is done, but let's make sure Gregory Dubois-Felsmann is happy since he filed it originally.

            swinbank John Swinbank made changes -
            Reviewers Gregory Dubois-Felsmann [ gpdf ]
            Status To Do [ 10001 ] In Review [ 10004 ]
            swinbank John Swinbank made changes -
            Epic Link DM-12880 [ 36602 ]
            swinbank John Swinbank made changes -
            Sprint AP S18-2 [ 677 ]
            Team System Management [ 12217 ] Alert Production [ 10300 ]
            tjenness Tim Jenness added a comment -

            Document build is technically not quite sorted out: https://github.com/lsst/LDM-294/pull/54

            swinbank John Swinbank added a comment -

            Tim Jenness — can we just assign this issue to you, then? You can pull those changes on to a ticket branch, and send it to Gregory for review when you're happy.

            tjenness Tim Jenness added a comment -

            Those changes are fixes to the makefile and travis file. I don't think Gregory Dubois-Felsmann cares about them. You might.

            swinbank John Swinbank added a comment -

            Well, do they belong on this ticket or not?

            tjenness Tim Jenness added a comment -

            The ticket says "fix document build" and the document build is currently broken. If you want to close this ticket and fix the build without a ticket that's fine. I can merge the PR myself without asking anyone to review it if you prefer.

            swinbank John Swinbank added a comment -

            I think since Gregory filed a ticket asking for the document build to be fixed (amongst other things), he probably cares enough about the document build being fixed to do a review and confirm that the build is, in fact, fixed. And if your changes are necessary to fix the build, it seems like they belong on this ticket.

            swinbank John Swinbank made changes -
            Assignee John Swinbank [ swinbank ] Tim Jenness [ tjenness ]
            swinbank John Swinbank made changes -
            Sprint AP S18-2 [ 677 ]
            swinbank John Swinbank made changes -
            Epic Link DM-12880 [ 36602 ]
            swinbank John Swinbank made changes -
            Team Alert Production [ 10300 ] Architecture [ 10304 ]
            swinbank John Swinbank made changes -
            Status In Review [ 10004 ] In Progress [ 3 ]
            tjenness Tim Jenness added a comment -

            Most of the work done on this ticket was by Wil O'Mullane, with help from Jonathan Sick via DM-13140, so Architecture is probably not the right team. I've just done a final 15 minute tweak to the build system right at the end so I shouldn't really be the assignee. I can confirm that travis builds the document fine on my branch.

            gpdf Gregory Dubois-Felsmann added a comment -

            Happy to review this when Tim Jenness is done.

            tjenness Tim Jenness added a comment -

            I'm done. The PR is at https://github.com/lsst/LDM-294/pull/54 on a user branch rather than a ticket branch because I wasn't sure at the time whether the broken-ness was meant to be there or not given that DM-13140 was completed and that was fixing the build (failures only occurred half the time).

            swinbank John Swinbank made changes -
            Status In Progress [ 3 ] In Review [ 10004 ]
            gpdf Gregory Dubois-Felsmann added a comment -

            It looks like things are generally much better.  I think productlist.tex is still an example of an intermediate that is being kept in the repo and could be suppressed.  On the other hand, I am wondering about ProductTree.pdf.  I think there may have been an intent that it, or the landscape version of it, would be kept around after autogeneration so that it could be used on its own, not just embedded in LDM-294.  If that's true, is there somewhere else it could be stashed, e.g., by LTD?

            gpdf Gregory Dubois-Felsmann made changes -
            Status In Review [ 10004 ] Reviewed [ 10101 ]
            tjenness Tim Jenness added a comment -

            Merged and now it seems to build okay and has been updated on lsst.io.

            tjenness Tim Jenness made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]

              People

              • Assignee:
                tjenness Tim Jenness
                Reporter:
                gpdf Gregory Dubois-Felsmann
                Reviewers:
                Gregory Dubois-Felsmann
                Watchers:
                Gregory Dubois-Felsmann, John Swinbank, Jonathan Sick, Kian-Tat Lim, Tim Jenness, Wil O'Mullane
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel