Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13140

Assist with fixing LDM-294

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Provide engineering assistance to the LDM-294 maintainers to fix build issues and address technical debt.

        Attachments

          Issue Links

            Activity

            jsick Jonathan Sick created issue -
            jsick Jonathan Sick made changes -
            Field Original Value New Value
            Epic Link DM-12788 [ 36406 ]
            jsick Jonathan Sick made changes -
            Link This issue relates to DM-13088 [ DM-13088 ]
            jsick Jonathan Sick made changes -
            Status To Do [ 10001 ] In Progress [ 3 ]
            jsick Jonathan Sick made changes -
            Component/s Design Documents [ 12816 ]
            Story Points 0.5
            jsick Jonathan Sick added a comment -

            John Swinbank, this PR should fix most of the issues you're seeing in DM-13088.

            I point out two additional issues in the GitHub PR that I uncovered but are beyond the scope of this ticket:

            • the make acronyms target isn't reproducible in CI (command not present).
            • the ProductTree.pdf file, when built from scratch at least, isn't well formatted (spans two pages, for example)
            jsick Jonathan Sick made changes -
            Reviewers John Swinbank [ swinbank ]
            Status In Progress [ 3 ] In Review [ 10004 ]
            swinbank John Swinbank added a comment -

            Thanks Jonathan Sick.

            Acronyms is a Wil O'Mullane special which is pretty opaque to me  — I hope he can enlighten us when he's back from his travels.

            jsick Jonathan Sick added a comment -

            Would you like this merged into your DM-13088 branch so that you can complete any final adjustments there, John Swinbank? This branch is based on the head of tickets/DM-13088.

            womullan Wil O'Mullane added a comment -

            the make file contains a target for prioduct tree - for the document I use a partial dpeth tree so it fit son one page
            ProductTree.tex: productlist.csv
            ./makeProductTree.py --depth=3

            womullan Wil O'Mullane added a comment -

            The acronyms script is in lsst-texmf/bin/acronyms.csh
            that needs to be in the path of the docker container for tex.

            jsick Jonathan Sick added a comment -

            To run acronyms.csh in the lsst-texmf Docker container I'll need to add Java and csh to that image. Is acronyms.csh used by all documents, or only LDM-294? If it's just LDM-294, I'd be tempted to add Java only to LDM-294's Travis CI environment.

            For the product tree; this is what it looks like when built in CI: https://ldm-294.lsst.io/v/DM-13140/ProductTree.pdf I'm guessing that the Travis environment has a different default font size or page size that we could explicitly set?

            womullan Wil O'Mullane added a comment -

            I use it in all my documents - I was discussing a Python Version and
            also perhaps having  a glossary option for it but that may take a while.

            womullan Wil O'Mullane made changes -
            Attachment signature.asc [ 30900 ]
            tjenness Tim Jenness added a comment -

            Do you have the java source code?

            gpdf Gregory Dubois-Felsmann added a comment -

            I see an apparent glitch in the ldm-294.lsst.io rendering of this ticket branch: Figure 10 (the DM product tree) is not visible - there's a blank space on page 20 of the rendering, showing only the figure caption.

            jsick Jonathan Sick added a comment -

            I've updated the lsst-texmf Docker container to include csh and the Java runtime, which let me run acronyms.csh in Travis CI.

            As Gregory Dubois-Felsmann says, the last thing to tackle is fixing the layout of ProductTree.pdf as it's made in CI.

            jsick Jonathan Sick made changes -
            Story Points 0.5 1.4
            jsick Jonathan Sick added a comment -

            I'm marking this ticket as done since Wil O'Mullane merged the corresponding ticket branch in LDM-294 onto DM-13088. He will fix up the ProductTree.pdf build there.

            jsick Jonathan Sick made changes -
            Resolution Done [ 10000 ]
            Status In Review [ 10004 ] Done [ 10002 ]

              People

              • Assignee:
                jsick Jonathan Sick
                Reporter:
                jsick Jonathan Sick
                Reviewers:
                John Swinbank
                Watchers:
                Gregory Dubois-Felsmann, John Swinbank, Jonathan Sick, Tim Jenness, Wil O'Mullane
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel