Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13154

Refine limits and labeling for color analysis plots

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_analysis
    • Labels:
      None
    • Story Points:
      12
    • Sprint:
      DRP S18-1, DRP S18-2, DRP S18-3, DRP S18-4, DRP S18-5, DRP S18-6
    • Team:
      Data Release Production

      Description

      The current settings for the color analysis plots are not ideal and sometimes misleading. Please refine them to optimal and representative values.

        Attachments

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment -

            The scope of this ticket is being increased to reflect requests and comments from Robert Lupton.  Further updates include:

            • increase magnitude threshold to HSC-I<22 for stars to include in polynomial fitting
            • adjust the fit order for color combinations with less curvature
            • use more sophisticated data "ranges" for fits (roughly the perpendicular line to a fit to the most linear part of the curve in gri color space.  Assess appropriate ranges for other color combinations as well)
            • make fits to several tracts (likely just the three RC2 tracts for now, see DM-11345) and then use roughly the average fit as a fixed line from which to calculate the distance statistics (so that the mean and stdDev have more meaning)
            • include the stdDev on the distance-from-polynomial-fit histograms
            • include color-color only (i.e. no fits) plots that include both stars and galaxies (and try to code by HSC-I CModel magnitude)
            • look into including Galactic Extinction corrections (we noticed a big shift in the VVDS field color-color locus and it is indeed at lower Galactic latitude, so consistent with GE effects, but we need to make sure).  It has been suggested that I look into the code mwdust written by Jo Bovy: https://github.com/jobovy/mwdust
            lauren Lauren MacArthur added a comment -

            I have implemented a per-field placeholder Galactic Extinction correction to confirm that the color shift in the VVDS field was indeed caused by GE.  A per-object Galactic Extinction correction will be implemented in DM-13519.  It looks like there is code in sims_photUtils (and dependencies) to do this, so DM-13519 will be an attempt to get that working with the analysis scripts rather than going to a third party package (as noted above). 

            lauren Lauren MacArthur added a comment - - edited

            Ok, this is finally ready for review. There is quite a lot added here and some of it is related to other tickets (see linked tickets for comments). This completes the work described in DM-13650, so is also meant to be a review of that ticket as well.  Preliminary calibrations for the HSC coefficients of DM-13651 are derived here. They already look pretty good for the gri color space (i.e. they compare well with the SDSS values, with differences that are consistent with filter differences).
            Further refinements are not really warranted until the per-object Galactic Extinction corrections of DM-13519 are included (next on my list).

            Example plots for the RC2 dataset (based on the w_2018_12 processing) can be seen at:
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12/UD_COSMOS_9813/plots/color/tract-9813/
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12/WIDE_VVDS_9697/plots/color/tract-9697/
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12/WIDE_GAMA15H_9615/plots/color/tract-9615/

            Also note that, as I discussed and agreed with Russell Owen, this branch includes the fix on DM-11162 (including the vast majority of Russell’s pep8 fixes on his ticket branch).

            yusra Yusra AlSayyad added a comment -

            So sorry for the delay on this! 

            I really love the density plotting in the plot-t9813-griCModel-wFit-fit.png-family plots!  It'd be helpful on the "noFit" plots as well (not on this ticket).

            Is the x-axis on the histogram on the right still "Distance to Polynomial fit (mmag)"?

            It looks like you missed coaddAnalysis.py when incorporating Russell's python standards fixes on his ticket branch. 

            Question: while I'm going through the pull request on github, would you like me to check to standards problems in the whole file as a way to get started on getting it ready for the stack or just the lines changed?

            lauren Lauren MacArthur added a comment -

            I really love the density plotting in the plot-t9813-griCModel-wFit-fit.png-family plots!  It'd be helpful on the "noFit" plots as well (not on this ticket).

             

            Ok, I'll make a ticket.

             

            Is the x-axis on the histogram on the right still "Distance to Polynomial fit (mmag)"?

             

            Yes.  I tried to make this clear by the color coding (green for the fit params in the left panel and a green histogram on the right).  I could change these to use the Principle Color fits, but I opted not too as the fits printed for wPerp and wPara on these are "live" (per field).  The fixed coeffs from averaging all 3 fields are those used in the plot-t9813-color_wPerp-psfMagHist.png plots (i.e. those are the "calibrated" ones that should be considered the authoritative numbers for the Principal Color analysis – I'm adding the coeffs used to those plots).  The fits per field are useful in case we have funky behavior in a given tract (this will also be revealed in the "calibrated" plots as the offset and likely stdev also will be significant).  I can change the histogram to plot the per-field wPerp fit if you think it would be more useful/less confusing.

             

            It looks like you missed coaddAnalysis.py when incorporating Russell's python standards fixes on his ticket branch. 

             

            Ah, thanks!  Will update.

             

            Question: while I'm going through the pull request on github, would you like me to check to standards problems in the whole file as a way to get started on getting it ready for the stack or just the lines changed?

             

            That's totally up to you.  This needs to be done, but we could isolate it all to another ticket (which I will also create)

             

            I'll ping you when the above mentioned changes are pushed.

            lauren Lauren MacArthur added a comment -

            Ok, this is ready for you to give it another look.  I now plot the fitted and hard-wired Principle Colors on the stellar locus plots, here is an example (note that the wPerp equations and histograms are the Principle Color numbers to be compared with the Ivezic et al. 2004 analysis):

             

            All other updated example plots for the RC2 dataset (based on the w_2018_12 processing) can be seen at:
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12a/UD_COSMOS_9813/plots/color/tract-9813/
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12a/WIDE_VVDS_9697/plots/color/tract-9697/
            https://lsst-web.ncsa.illinois.edu/~lauren/lauren/lauren/DM-13154/w_2018_12a/WIDE_GAMA15H_9615/plots/color/tract-9615/

             

            I created DM-14195 for your request above and also DM-14196 to explore deriving the Principle Colors and their respective scatters for HSC data using a variety of magnitude thresholds.

            yusra Yusra AlSayyad added a comment -

            Thanks for your patience

            lauren Lauren MacArthur added a comment -

            Thanks Yusra!  Merged to master.


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                lauren Lauren MacArthur
                Reviewers:
                Yusra AlSayyad
                Watchers:
                Hsin-Fang Chiang, John Swinbank, Lauren MacArthur, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel