Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13159

Utilize new polynomials library in meas_astrom

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw
    • Story Points:
      4

      Description

      DM-13065 adds a new low-level polynomials library to afw::math, incorporating but heavily modifying code from afw.math.ChebyshevBoundedField, meas.astrom.PolynomialTransform, and shapelet.

      The new, unused, not-quite-working TAN-SIP fitter code should be rewritten on top of this new library. It should be possible to remove a lot of duplicate code.

      It might also make more sense to rework this as a TAN+Chebyshev fitter whose results can be transformed to SIP for FITS-friendly persistence (while keeping our internal representation in Chebyshev). This should be similarly easy with the new polynomials library, and should be much more robust.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -

            Calling this Won't Fix because I'm not sure we'll ever use the referenced fitter; the problem it was intended to solved is being tackled by a different one that holds the distortions fixed from cameraGeom.  I'm not quite ready to try to remove that fitter, because I've lost track of how various parts of it might be integrated with code that is in use, but I wouldn't be opposed to it if someone else did that homework.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Jim Bosch
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.