My first comment is that I am unhappy using "bf" as an abbreviation for "brighter-fatter" in so many really visible places. Our standards are to spell things out unless they are well established norms, as per this entry in the style guide. I guess the question is whether "bf" is now sufficiently well established to qualify.
If you do change this I suggest changing "bf to "brighterFatter" in the dataset names (which neatly eliminates the collision with the name used by obs_subaru for the brighter-fatter kernel) and the task name BFTask -> BrighterFatterTask and the task _DefaultName to "brighterFatter".
I also think the name BFTask is too vague because it sounds like a task that applies compensation to data for the brighter-fatter effect, but in this case it appears to compute a kernel that can be used by other code to apply such compensation. Consider a name like MeasureBrighterFatterTask.
(Note: if nothing else, you should rename BFTask to BfTask – ugh – as per this standard, hence SkyWcs, LsstSimMapper, etc.).