Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13317

Filtered table display in image overlay fails to apply the filter

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Firefly
    • Labels:
    • Templates:
    • Story Points:
      1
    • Sprint:
      SUIT Sprint 2018-10
    • Team:
      Science User Interface

      Description

      This is in the test build Tatiana Goldina is running in response to DM-13099.

      I've queried two tables on PDAC: AllWISE catalog sources and WISE All-Sky (4 band) single-epoch sources. I've identified a cluster of sources in the single-epoch data that I suspect come from a single object, and I'm trying to identify that object in the AllWISE catalog.

      I drew a box around the cluster in the single-epoch data and used it as a filter.

      I then tried to copy the filter specification from the "filter panel" dialog from the single-epoch table:

      "ra" > 0.9909882575279574;"ra" < 0.992205622144179;"decl" > 0.0072994581062348135;"decl" < 0.009400119782442063"

      to the filter panel on the AllWISE table. That didn't work at all - a separate problem? - so instead I copied the two expressions from the column headers from the one table to the other: "> 0.9909882575279574; < 0.992205622144179" for ra and "> 0.0072994581062348135; < 0.009400119782442063" for decl.

      That worked, and the row I wanted ended up selected in the table. However, the selection was not successfully applied to the coverage image for the AllWISE table, only for the single-epoch table. See screenshots.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                xiuqin Xiuqin Wu [X] (Inactive)
                Reporter:
                gpdf Gregory Dubois-Felsmann
                Reviewers:
                Xiuqin Wu [X] (Inactive)
                Watchers:
                Gregory Dubois-Felsmann, Trey Roby, Xiuqin Wu [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel