Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13356

newinstall.sh doesn't work properly with tcsh when loadLSST.csh is sourced from arbitrary directory

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: lsst
    • Labels:
      None
    • Team:
      SQuaRE

      Description

      I see from DM-10587 that the stack should work with tcsh but it doesn't (fully). If you are currently in the LSST_HOME directory when you do source loadLSST.csh then it works fine. But if you are anywhere else source /path/to/loadLSST.csh then it fails to determine LSST_HOME.

      The problem is that $0 doesn't work in `tcsh` when a script has been sourced. The following code replacement seems to work in my limited testing:

      set called=($_)
      set split = ($called:as/ / /)
      set LSST_HOME = `dirname $split[2]`
      set LSST_HOME = `cd ${LSST_HOME} && pwd`
      

        Attachments

          Issue Links

            Activity

            No work has yet been logged on this issue.

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              erykoff Eli Rykoff
              Watchers:
              Eli Rykoff, Kian-Tat Lim, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.