Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13386

DecamCpIsrTask should delegate more to IsrTask

    XMLWordPrintable

    Details

    • Story Points:
      2

      Description

      obs_decam's DecamCpIsr reimplements the readIsrData method without delegating to the base class implementation even though it only needs to change a couple of dataset type names, leading to a lot of code duplication.  The base IsrTask should provide hooks for these sorts of changes that do not require full reimplementation of the method.

        Attachments

          Issue Links

            Activity

            Hide
            czw Christopher Waters added a comment -

            Set to invalid, as this appears to have been fully implemented elsewhere.

            Show
            czw Christopher Waters added a comment - Set to invalid, as this appears to have been fully implemented elsewhere.
            Hide
            tjenness Tim Jenness added a comment -

            Christopher Waters is this ticket now irrelevant and can be closed?

            Show
            tjenness Tim Jenness added a comment - Christopher Waters is this ticket now irrelevant and can be closed?

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Christopher Waters, Jim Bosch, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.