Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-1339

Unit tests failing

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: shapelet
    • Labels:
      None
    • Team:
      Data Release Production

      Description

      When building on MacOS 10.9 with clang 6 two shapelet unit tests are failing.

      tests/testMatrixBuilder.py
       
      .F.....
      ======================================================================
      FAIL: testConvolvedCompoundMatrixBuilder (__main__.MatrixBuilderTestCase)
      ----------------------------------------------------------------------
      Traceback (most recent call last):
        File "tests/testMatrixBuilder.py", line 310, in testConvolvedCompoundMatrixBuilder
          self.assertClose(numpy.dot(matrix1D, coefficients), checkVector, rtol=1E-14)
        File "/Users/rowen/LSST/lsstsw/stack/DarwinX86/utils/9.2+9/python/lsst/utils/tests.py", line 328, in assertClose
          testCase.assertFalse(failed, msg="\n".join(msg))
      AssertionError: 1/50 elements differ with rtol=1e-14, atol=2.22044604925e-16
      0.175869366369 != 0.175869366369 (diff=1.99840144433e-15/0.175869366369=1.13629876856e-14)
       
      ----------------------------------------------------------------------
      Ran 7 tests in 0.201s
       
      FAILED (failures=1)

      and

      tests/testMultiShapelet.py
       
      ...F...
      ======================================================================
      FAIL: testConvolveGaussians (__main__.MultiShapeletTestCase)
      ----------------------------------------------------------------------
      Traceback (most recent call last):
        File "tests/testMultiShapelet.py", line 88, in testConvolveGaussians
          self.compareMultiShapeletFunctions(msf3a, msf3b)
        File "/Users/rowen/LSST/lsstsw/build/shapelet/python/lsst/shapelet/tests.py", line 107, in compareMultiShapeletFunctions
          self.compareShapeletFunctions(sa, sb, rtolEllipse=rtolEllipse, rtolCoeff=rtolCoeff)
        File "/Users/rowen/LSST/lsstsw/build/shapelet/python/lsst/shapelet/tests.py", line 86, in compareShapeletFunctions
          rtol=rtolEllipse)
        File "/Users/rowen/LSST/lsstsw/stack/DarwinX86/utils/9.2+9/python/lsst/utils/tests.py", line 328, in assertClose
          testCase.assertFalse(failed, msg="\n".join(msg))
      AssertionError: 1/5 elements differ with rtol=1e-14, atol=2.22044604925e-16
      2.44929359829e-16 != 1.13310777953e-15 (diff=8.881784197e-16/1.13310777953e-15=0.783842839795)
       
      ----------------------------------------------------------------------
      Ran 7 tests in 0.243s
       
      FAILED (failures=1)

        Attachments

          Issue Links

            Activity

            rowen Russell Owen added a comment -

            Duplicate of 1305. Sorry


              People

              Assignee:
              jbosch Jim Bosch
              Reporter:
              rowen Russell Owen
              Watchers:
              Mario Juric, Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.