Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13413

blueocean 1.4.0 pipeline view ignoring clicks

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Description

      After a jenkins core + blueocean update to 1.4.0, clicks in the build pipeline view to change between branches are frequently ignored.  It appears that this is only happening for builds that are actively running.

      A search of the upstream jenkins Jira did not find an existing issues thats even in the ballpark.  A screencast should be made to report upstream.  Downgrading BO to 1.3.x may be the best option.

        Attachments

          Issue Links

            Activity

            jhoblitt Joshua Hoblitt added a comment -

            I've made a screencast, which Russell Owen has confirmed is representative of the problem, and reported it in the upstream jenkins jira.

            jhoblitt Joshua Hoblitt added a comment - - edited

            I've done a quick test and downgrading to only the blueocean family of plugins to 1.3.5 doesn't raise an errors in the logs.  I've merged the rollback to master and suspend submission of new jenkins builds in the production env.  As soon as the production work queue drains, I will do the rollback.

            jhoblitt Joshua Hoblitt added a comment -

            Upstream has reported that this issue is fixed in the 1.5.0-beta-1 release. 1.5.0-beta-2 is out and seems to be working in a test env. I'm going to close this ticket out and do the production update under DM-13258 once 1.5.0 final is released.


              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                Joshua Hoblitt, Russell Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel