Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13579

Apply jointcal_wcs and jointcal_photoCalib directly in coaddition code

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_tasks
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      DRP S18-3, DRP S18-4, DRP S18-5, DRP S18-6, DRP F18-1
    • Team:
      Data Release Production

      Description

      Our coaddition code currently delegates applying jointcal/meas_mosaic outputs to specialized code in meas_mosaic.  Since meas_mosaic and jointcal now produce compatible standardized outputs*, the code to apply them should move to the coaddition code.

      This will mean that we start using a PhotoCalib object instead of meas_mosaic's non-standard fcr dataset (meas_mosaic currently outputs both, jointcal only the former) for the photometric correction, and it should allow us to remove any imports of meas_mosaic from pipe_tasks.

      *We still need to make sure that meas_mosaic and jointcal are consistent about whether the output PhotoCalib includes the Jacobian of the WCS.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -

            I'm not sure who should do this, but I probably never should have volunteered myself.

            Parejkoj John Parejko added a comment - - edited

            Is DM-15254 a duplicate of this, or just one piece of the necessary work?

            jbosch Jim Bosch added a comment -

            Looks like they're just duplicates.

            jbosch Jim Bosch added a comment -

            Closing this as a duplicate of DM-15254.


              People

              • Assignee:
                Unassigned
                Reporter:
                jbosch Jim Bosch
                Watchers:
                Jim Bosch, John Parejko, John Swinbank, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel