Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-13792

make chip/ccd/ccdId and visit/visitId names more consistent

    XMLWordPrintable

    Details

    • Story Points:
      0.5
    • Team:
      Alert Production

      Description

      The mixed use of chip/ccd/ccdId and visit/visitId in jointcal has gotten out of hand. I need to just decide on one to use and use it everywhere.

      I'm going to suggest going with chipId and visitId as the identifiers.

        Attachments

          Activity

          Hide
          jbosch Jim Bosch added a comment -

          Recommend sensorId for compatibility with Butler Gen3 (assuming it gets approved there, too).

          Show
          jbosch Jim Bosch added a comment - Recommend sensorId for compatibility with Butler Gen3 (assuming it gets approved there, too).
          Hide
          Parejkoj John Parejko added a comment -

          Thanks for that suggestion.

          I should also use this to rename OneTPPerShoot->OneTangentPlanePerVisit.

          Show
          Parejkoj John Parejko added a comment - Thanks for that suggestion. I should also use this to rename OneTPPerShoot -> OneTangentPlanePerVisit .
          Hide
          Parejkoj John Parejko added a comment -

          Also check for and clean up e.g. visitp, chipp post-fix Hungarian notation (e.g. in ConstrainedAstrometryModel::getVisitTransfo, it should probably be visitMapping).

          Show
          Parejkoj John Parejko added a comment - Also check for and clean up e.g. visitp , chipp post-fix Hungarian notation (e.g. in ConstrainedAstrometryModel::getVisitTransfo , it should probably be visitMapping ).
          Hide
          Parejkoj John Parejko added a comment -

          Note: gen3 butler has gone with `detector` and `astro_metadata_translator` has gone with `detector_num` for the numeric identifier.

          Show
          Parejkoj John Parejko added a comment - Note: gen3 butler has gone with `detector` and `astro_metadata_translator` has gone with `detector_num` for the numeric identifier.
          Hide
          tjenness Tim Jenness added a comment -

          detector_num was chosen because there are also detector_serial, and detector_name so it seemed best to be explicit about the distinction of number, name, and serial.

          Show
          tjenness Tim Jenness added a comment - detector_num was chosen because there are also detector_serial, and detector_name so it seemed best to be explicit about the distinction of number, name, and serial.

            People

            Assignee:
            Parejkoj John Parejko
            Reporter:
            Parejkoj John Parejko
            Watchers:
            Jim Bosch, John Parejko, John Swinbank, Tim Jenness
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated: