Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14296

blueocean junit test reporting blank when following link from classic ui -> BO

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Continuous Integration
    • Labels:
      None

      Description

      There was a report on #dm-square yesterday of blueocean show no test results when there was a failure and all tests were visible in the classic UI. This was fixed by upgrading from BO 1.5.0-beta-2 to 1.5.0, which was planned to resolve the issue with links to triggered builds being broken. This resolved the problem with the reported build:

      https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/27893/pipeline/46/

      but it appears to have introduced a bug that results no test results are showing under BO when following a link from the classic UI test result view -> BO.

        Attachments

          Issue Links

            Activity

            jhoblitt Joshua Hoblitt created issue -
            jhoblitt Joshua Hoblitt made changes -
            Field Original Value New Value
            Epic Link DM-13784 [ 39331 ]
            jhoblitt Joshua Hoblitt made changes -
            Link This issue is triggered by DM-14279 [ DM-14279 ]
            jhoblitt Joshua Hoblitt made changes -
            Risk Score 0
            jhoblitt Joshua Hoblitt made changes -
            Description There was a report on #dm-square yesterday of blueocean show no test results when there was a failure and all tests were visible in the classic UI. This was fixed by upgrading from BO {{1.5.0-beta-2}} to {{1.5.0}}, which was planned to resolve the issue with links to triggered builds being broken. This resolved the problem with the reported build:

            https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/27893/pipeline/46/

            but it appears to have introduced a bug that results no test results showing under BO when following a link from the classic UI test result view -> BO.
            There was a report on #dm-square yesterday of blueocean show no test results when there was a failure and all tests were visible in the classic UI. This was fixed by upgrading from BO {{1.5.0-beta-2}} to {{1.5.0}}, which was planned to resolve the issue with links to triggered builds being broken. This resolved the problem with the reported build:

            https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/27893/pipeline/46/

            but it appears to have introduced a bug that results no test results are showing under BO when following a link from the classic UI test result view -> BO.
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            It looks like exiting to the classic UI and returning to BO, viewing the classic UI test results or not, also triggers the problem.

            Show
            jhoblitt Joshua Hoblitt added a comment - It looks like exiting to the classic UI and returning to BO, viewing the classic UI test results or not, also triggers the problem.
            jhoblitt Joshua Hoblitt made changes -
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            Reported to upstream.

            Show
            jhoblitt Joshua Hoblitt added a comment - Reported to upstream.
            jhoblitt Joshua Hoblitt made changes -
            Remote Link This issue links to "JENKINS-51110 - no test results visible in blueocean when following link from classic -> BO (Web Link)" [ 16900 ]
            jhoblitt Joshua Hoblitt made changes -
            Story Points 0.25
            jhoblitt Joshua Hoblitt made changes -
            Epic Link DM-13784 [ 39331 ] DM-11756 [ 34208 ]
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            There has been no motion on this upstream. This should be followed up on after the deployment of DM-15598 to see if this issue has been resolved.

            Show
            jhoblitt Joshua Hoblitt added a comment - There has been no motion on this upstream. This should be followed up on after the deployment of DM-15598 to see if this issue has been resolved.
            jhoblitt Joshua Hoblitt made changes -
            Link This issue relates to DM-15598 [ DM-15598 ]
            jhoblitt Joshua Hoblitt made changes -
            Epic Link DM-11756 [ 34208 ] DM-14567 [ 94448 ]
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            This issue seems to have been resolved and has tested as no longer being present in the production env.

            Show
            jhoblitt Joshua Hoblitt added a comment - This issue seems to have been resolved and has tested as no longer being present in the production env.
            jhoblitt Joshua Hoblitt made changes -
            Resolution Done [ 10000 ]
            Status To Do [ 10001 ] Done [ 10002 ]

              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                jhoblitt Joshua Hoblitt
                Watchers:
                Gabriele Comoretto, Joshua Hoblitt, Kian-Tat Lim, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel