Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14349

Possible race condition in ApPipeTask

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ap_pipe
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      AP S19-4, AP S19-5, AP S19-6
    • Team:
      Alert Production

      Description

      A run of ap_pipe on ap_verify_hits2015, visit=411657, and no CCDs in the dataId failed on CCD 35 with a Butler error about no defects existing. This error did not occur when running CCD 35 by itself, or with ccdnum=33..38, suggesting it's associated with large parallel runs.

      Given that defects are read-only from ap_pipe's point of view, this may be a bug in the Butler rather than ap_pipe.

        Attachments

          Activity

          krzys Krzysztof Findeisen added a comment -

          My initial report was wrong; the failure happens with CCD 2, not CCD 35 (I got confused because it's HDU 35). It does occur if I just run CCD 2 by itself, including in single-threaded mode. The root cause is no defect file ingested for that CCD.

          Since it's not a race condition, or even a bug in the defects code, I'm closing this issue as invalid.


            People

            • Assignee:
              krzys Krzysztof Findeisen
              Reporter:
              krzys Krzysztof Findeisen
              Watchers:
              Eric Morganson, Krzysztof Findeisen, Meredith Rawls
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel