Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14372

Change log level on wcs creation failure from WARN to DEBUG

    Details

    • Type: Improvement
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      0.1
    • Sprint:
      DRP S18-6
    • Team:
      Data Release Production

      Description

      Change log level on wcs creation failure from WARN to DEBUG

        Attachments

          Activity

          mfisherlevine Merlin Fisher-Levine added a comment -

          Following length OOB discussion with Robert, following the talk about this in the DM room, this was the course of action decided upon.

          Once Gen3 Butler comes along, and supertask, there might be enough context about the ongoing processing to deal with this better, but for now, this reduces chatter and cleans things up.

          rhl Robert Lupton added a comment -

          The problem is that we don't have enough information here to either

          1. Log a fatal warning and abort; or
          2. Silently proceed

          Both are legitimate, depending on the dataset, but the butler doesn't provide enough context (yet).  Logging at WARN level is inappropriate when the data is fine.

          rhl Robert Lupton added a comment -

          Looks good

          mfisherlevine Merlin Fisher-Levine added a comment -

          Merged.


            People

            • Assignee:
              mfisherlevine Merlin Fisher-Levine
              Reporter:
              mfisherlevine Merlin Fisher-Levine
              Reviewers:
              Robert Lupton
              Watchers:
              Merlin Fisher-Levine, Robert Lupton
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel