Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14793

Define procedures for training/validating photometric redshifts in DRP

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: DM Subsystem Science
    • Labels:
      None
    • Team:
      DM Science

      Description

      In trying to define a test script for LVV-T16, I was reminded that we may not be able to "just run" an externally-developed photometric redshift code during DRP; many modern photometric redshift codes require some kind of training step, which typically requires as input both photometry from the survey for which redshifts are being estimated and a sample of spectroscopic or otherwise more secure redshift estimates for a subset of the catalog.  Furthermore, there are frequently multiple cycles of training, estimation, and validation before the release of any particular photometric redshift catalog.

      The work of collecting, curating, and standardizing spectroscopic training data is (to my understanding) beyond the scope of DM, but DM outputs are also needed inputs to this training step.  At some level, I believe that train/estimate/validate iteration is also outside DM scope; all I think we've signed up for is a final "estimation" step, which cannot be done in isolation.

      The only way I see to resolve this without increasing DM scope or delaying the release of photometric redshifts until well after each main DR would be to define a procedure that involves the external scientists responsible for photometric redshift estimation directly in the data release process itself.

      Note: I don't recall any mention of this in DMTN-049, but I should read again to check.

        Attachments

          Issue Links

            Activity

            mgraham Melissa Graham added a comment -

            Probably no need to check DMTN-049, it's more concerned with the science drivers behind (1) the choice of which photo-z algorithm and (2) the format in which the results are presented in the Object catalog. DMTN-049 does not have a solution for the problem you identify, but it could serve as the place where we work out the solution (it's got a preliminary "roadmap" for the process).

            jbosch Jim Bosch added a comment -

            Closing as a duplicate of DM-6367.


              People

              • Assignee:
                Unassigned
                Reporter:
                jbosch Jim Bosch
                Watchers:
                Jim Bosch, Leanne Guy, Melissa Graham, Robert Lupton, Zeljko Ivezic
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel