Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14851

create_xlinkdocs.sh uses obsolete cp flag

    XMLWordPrintable

    Details

    • Team:
      SQuaRE

      Description

      The cp command in line 159 of the script uses both the -a and -r flags. -a implies -R, which is the modern replacement for -r, on all platforms. For some reason, this is now being executed on macOS, which complains and errors, unlike CentOS.

        Attachments

          Issue Links

            Activity

            ktl Kian-Tat Lim created issue -
            ktl Kian-Tat Lim made changes -
            Field Original Value New Value
            Risk Score 0
            ktl Kian-Tat Lim added a comment -

            PR https://github.com/lsst-sqre/ci-scripts/pull/53 from my fork. Please merge if it looks good.

            ktl Kian-Tat Lim made changes -
            Reviewers Joshua Hoblitt [ jhoblitt ]
            Status To Do [ 10001 ] In Review [ 10004 ]
            ktl Kian-Tat Lim made changes -
            Assignee Kian-Tat Lim [ ktl ]
            jhoblitt Joshua Hoblitt added a comment -

            The fix is good, and I've merged it, but I don't know why this is all of a sudden running on OSX – this is almost certainly fallout from DM-14631 that needs to be fixed.

            jhoblitt Joshua Hoblitt made changes -
            Status In Review [ 10004 ] Reviewed [ 10101 ]
            jhoblitt Joshua Hoblitt made changes -
            Link This issue is triggered by DM-14631 [ DM-14631 ]
            jhoblitt Joshua Hoblitt added a comment -

            It looks like the SKIP_DOCS env var was being set to true for all of the lsst_distrib platforms even though it is declared as false in the config file. One of the refactors under DM-14631 was a cleanup of relying on env vars being set by calling methods. This wasn't caught in testing as osx was disable in the test env. TL;DR the clean build is now working as intended but apparently the doc build hasn't been run on osx for a while, if ever.

            ktl Kian-Tat Lim made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]

              People

              Assignee:
              ktl Kian-Tat Lim
              Reporter:
              ktl Kian-Tat Lim
              Reviewers:
              Joshua Hoblitt
              Watchers:
              Joshua Hoblitt, Kian-Tat Lim
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: