Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-14941

mysql-proxy issues with mariadb 10.2.14

    Details

    • Type: Story
    • Status: Done
    • Priority: Critical
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Qserv
    • Labels:
    • Templates:
    • Story Points:
      6
    • Sprint:
      DB_F18_06
    • Team:
      Data Access and Database

      Description

      We have seen issues with some clients failing to communicate with qserv after upgrade to mariadb 10.2.14. Two notable cases are JDBC (see DM-14924) and nagios test script which is Perl script using DBI.

      JDBC workaround was to downgrade to older version of JDBC. I think usePipelineAuth connection attribute is a suspect but I remember Kenny was playing with in recent JDBC is and it did not help much, so there may be other reason for it.

      Nagios script has trouble on Ubuntu but works fine on CentOS7, I think the difference is due to older version of mysqlclient installed on CentOS7 (I had used system-installed Perl DBI).

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  salnikov Andy Salnikov
                  Reporter:
                  salnikov Andy Salnikov
                  Watchers:
                  Andy Salnikov, Brian Van Klaveren, Fritz Mueller, Kenny Lo
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Summary Panel