Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-15523

geom has random failure on macOS in polynomials test

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: geom
    • Labels:
      None

      Description

      Some builds are failing on macOS in test_polynomials. It seems that the test is unstable in that it sometimes passes and sometimes fails.

      Example failure:

      Failed test output:
      tests/test_polynomials
       
      Running 9 test cases...
      a=0.2272165537183282, b=0.2272165537183142, diff=1.398881011027697e-14 > 1.009044198056236e-14
      tests/test_polynomials.cc:398: error: in "simplified2d": check compare(a1, b1, 100*DEFAULT_RTOL) has failed
      a=-0.01667616780189118, b=-0.01667616780189041, diff=7.771561172376096e-16 > 7.405706182468739e-16
      tests/test_polynomials.cc:398: error: in "simplified2d": check compare(a1, b1, 100*DEFAULT_RTOL) has failed
      a=0.0221159430012603, b=0.02211594300126229, diff=1.998401444325282e-15 > 9.821451652519151e-16
      tests/test_polynomials.cc:398: error: in "simplified2d": check compare(a1, b1, 100*DEFAULT_RTOL) has failed
      a=0.0221159430012598, b=0.02211594300126181, diff=2.012279232133096e-15 > 4.910725826259466e-16
      tests/test_polynomials.cc:402: error: in "simplified2d": check compare(a1, b1, 50*DEFAULT_RTOL) has failed
      a=-0.02074950336545145, b=-0.02074950336544967, diff=1.77635683940025e-15 > 9.214630554344155e-16
      tests/test_polynomials.cc:398: error: in "simplified2d": check compare(a1, b1, 100*DEFAULT_RTOL) has failed
      a=-0.0207495033654517, b=-0.02074950336545071, diff=9.853229343548264e-16 > 4.60731527717222e-16
      tests/test_polynomials.cc:402: error: in "simplified2d": check compare(a1, b1, 50*DEFAULT_RTOL) has failed
       
      *** 6 failures are detected in the test module "polynomials"
      

      Master does seem to build fine some of the time. Running the test gives a different answer each time so there seems to be a repeatability issue.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -

            This is ready for review; anyone interested and available to do so should, as this is currently broken on master.  I'd especially like a reviewer who could try building this on OS X, but if I can't get one soon I'll merge without review on the assumption that "probably fixed" is better than "definitely broken".

             

            tjenness Tim Jenness added a comment -

            I can confirm this fixes my problem.


              People

              • Assignee:
                jbosch Jim Bosch
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Tim Jenness
                Watchers:
                Jim Bosch, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel