Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-15838

Modify Ack Timer for AuxDevice wait for xfer_params ack

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: cp_pipe
    • Labels:
      None

      Description

      There have been issues with getting a successful transfer of readout params to the forwarders. This seemed a sometimes intermittent problem that was caused by 

      not getting a proper ack from the forwarder about 10% of the time. After analysis, the xfer_params ack is returning SO quickly that calling the 'clear_forwarder_response_state'

      method immediately after publishing the xfer_params message  left too litle time for the ack response code to begin listening, as the response is returned in another thread. The fix here was simple, and painfully obvious in hindsight - clear the state first and then publish the xfer_params message. The debug timer has also been replaced with a progressive ack timer.
      This is an important fix, because a FAULT state is entered when time exceeds the limit for the xfer_params_ack to return.

        Attachments

          Activity

          jparsons James Parsons added a comment -

          commit f3c96776f5a951c2b94c9b456918241a8216343d


            People

            • Assignee:
              jparsons James Parsons
              Reporter:
              jparsons James Parsons
              Watchers:
              James Parsons
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel