Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-15851

sconsUtils does not reliably remove the .failed file

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • sconsUtils
    • None
    • Arch 2018-10-01, Arch 2018-10-08, Arch 2018-10-15
    • Architecture

    Description

      Following the merge of DM-11693, we are discovering that sconsUtils is no longer deleting the .xml.failed file when it is re-run. The "running tests twice as part of install" problem has been fixed but normal developer workflow of typing scons, getting a failure, fixing the failure, typing scons again, is now broken. This is because the second time you type scons the .failed file is not removed, so pytest now passes but sconsUtils sees the .failed file and stops everything and reports that there was a problem (when there wasn't). Being forced to manually remove the .failed file is annoying.

      Attachments

        Issue Links

          Activity

            I have a fix in, this should obliterate files when you are not performing an install, and preserve the files if you are doing an install

            bvan Brian Van Klaveren added a comment - I have a fix in, this should obliterate files when you are not performing an install, and preserve the files if you are doing an install

            Jenkins job: 28745, passed linux so far, still waiting on Mac.

            I tried testing this locally with a test case that fails and it seems to be working as intended.

            bvan Brian Van Klaveren added a comment - Jenkins job: 28745, passed linux so far, still waiting on Mac. I tried testing this locally with a test case that fails and it seems to be working as intended.

            tjenness I think this should be fixed adequately. I ran a CI 10/12/2018 (job #28844) and it seems to be behaving as normal when running scons directly.

            bvan Brian Van Klaveren added a comment - tjenness I think this should be fixed adequately. I ran a CI 10/12/2018 (job #28844) and it seems to be behaving as normal when running scons directly.
            tjenness Tim Jenness added a comment -

            I can confirm that this fixes the problem for me.

            tjenness Tim Jenness added a comment - I can confirm that this fixes the problem for me.

            Merged.

            bvan Brian Van Klaveren added a comment - Merged.

            People

              bvan Brian Van Klaveren
              tjenness Tim Jenness
              Tim Jenness
              Brian Van Klaveren, Eli Rykoff, Kian-Tat Lim, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.