Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16183

w_2018_41 coaddDriver is broken with detectCoaddSources API changes

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_drivers
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      DRP F18-5
    • Team:
      Data Release Production

      Description

      Looks like the API change in DM-15663 broken coaddDriver and gave the following error:

       Traceback:
      Traceback (most recent call last):
        File "/software/lsstsw/stack_20181012/stack/miniconda3-4.5.4-fcd27eb/Linux64/ctrl_pool/16.0-3-gbc759ec+15/python/lsst/ctrl/pool/parallel.py", line 509, in logOperation
          yield
        File "/software/lsstsw/stack_20181012/stack/miniconda3-4.5.4-fcd27eb/Linux64/pipe_drivers/16.0-6-gf9cb114+19/python/lsst/pipe/drivers/coaddDriver.py", line 323, in coadd
          self.detectCoaddSources.write(coadd, detResults, patchRef)
      TypeError: write() takes 3 positional arguments but 4 were given
      

      One command to reproduce is:

      coaddDriver.py  /datasets/hsc/repo --calib /datasets/hsc/repo/CALIB/ --rerun RC/w_2018_41/DM-16011:private/user/name --batch-type=slurm --mpiexec='-bind-to socket' --job  bug --time 600 --cores 24  --id tract=9697 patch=4,8 filter=HSC-I --selectId ccd=0..8^10..103 visit=35892^36140^36144
      

        Attachments

          Issue Links

            Activity

            hchiang2 Hsin-Fang Chiang added a comment -

            The same interface detectCoaddSources.write was used in multiBandDriver too, so it probably makes sense to update that together.

            yusra Yusra AlSayyad added a comment -

            He said that multiBandDriver worked before merging DM-15663, but I'll double check.

            yusra Yusra AlSayyad added a comment -

            Hsin-Fang Chiang Would you review?

            I confirmed that it properly wrote out data products: /datasets/hsc/repo/rerun/private/yusra/test_coaddDriver_fixed/deepCoadd-results/HSC-I/9697/4,8

            I think Nate didn't notice that line in mutliband because our normal RC2's don't rerun detection if it's already been run in coaddDriver.

            hchiang2 Hsin-Fang Chiang added a comment -

            Looks good. Thanks for the quick fix.


              People

              • Assignee:
                yusra Yusra AlSayyad
                Reporter:
                hchiang2 Hsin-Fang Chiang
                Reviewers:
                Hsin-Fang Chiang
                Watchers:
                Hsin-Fang Chiang, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel