Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16226

jointcal constrained photometry model is not better than processCcd photometry on DC2 run1.2

    Details

    • Type: Bug
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: jointcal
    • Labels:
      None

      Description

      From a set of 7 visits from DESC DC2 Run1.2p I am taking 1 visit as an arbitrary reference and for each matched sources in the other visits I compute the difference of magnitude using 1- the `processCcd` calibration and 2- the `jointcal` calibration from the default constrained model.

      The dispersion (19.9 mmag) is identical in both cases which looks very surprising. The size of the dispersion also looks very large. 

      In order to reproduce the problem the data are available on `lsst-dev:/home/boutigny/2018-10-11` and the notebook to reproduce the plot is on: `https://github.com/boutigny/LSST_notebooks/blob/master/DC2/multi_visit_Joincal.ipynb`

      I am not excluding an error on my side or a misusage of `jointcal`

        Attachments

          Issue Links

            Activity

            Parejkoj John Parejko added a comment -

            Try running jointcal with the defaults: that will use the constrained model for both astrometry and photometry, with a 5th and 7th order polynomial, respectively. What version are you running?

            The "simple" models are just extensions of the processCcd model (one model per ccd/visit: 2d polynomial for astrometry, one calibration factor for photometry). They are primarily useful for debugging or fitting non-mosaic camera data.

            boutigny Dominique Boutigny added a comment -

            We should also keep in mind that the astrometry fit is not giving very good results either. Running `jointcal` with default configuration I get an astrometric dispersion = 11.4 mas (mag<21) to be compared to 7.9 mas with the processCcd astrometry (which is also not particularly good given an almost perfect reference catalog).
            I think that we cannot exclude a problem in the reference catalog itself. I am excluding a problem in the simulation as I got similar results with phosim.  

            Parejkoj John Parejko added a comment - - edited

            Based on the discussion on slack, it appears to me that the reason jointcal doesn't do better than processCcd on this imsim data, is that there is nothing for it to fit beyond processCcd's model. Quoting myself from slack:

            If there are no throughput variations due to flat fielding, optics or atmosphere transparency, then there's really no way for jointcal (single value per sensor+focal plane polynomial per visit) to do better than processCcd (single value per sensor/visit).

            Parejkoj John Parejko added a comment -

            Can we close this as Invalid or Won't Fix, due to DC2 not having any photometric distortions for jointcal to model, and the known issues with the refcat?

            swinbank John Swinbank added a comment -

            Yes.


              People

              • Assignee:
                Unassigned
                Reporter:
                boutigny Dominique Boutigny
                Watchers:
                Dominique Boutigny, Eli Rykoff, James Chiang, Jim Bosch, John Parejko, John Swinbank, Robert Lupton
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel