Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16690

Change totFlux column names in imageDifferenceTask

    Details

      Description

      The direct image, forced flux columns created in imageDifferenceTask are not currently usable with slots and therefore awkward to use with calibration objects. This ticket will change the names to ip_diffim_forced_PsfFlux_[value] and the associated slot_forcedDirectFlux. The ticket will also propagate the PsfFlux plugin flag columns to the DiaSource catalog produced by ip_diffim.

        Attachments

          Activity

          Hide
          cmorrison Chris Morrison added a comment -

          Upon further review of how slots get defined I am only implementing the name change and addition of copying over the rest of the columns output by the PsfFlux plugin. Creating new slots seems to require a more fundamental change in the API of SourceTables. 

          Show
          cmorrison Chris Morrison added a comment - Upon further review of how slots get defined I am only implementing the name change and addition of copying over the rest of the columns output by the PsfFlux plugin. Creating new slots seems to require a more fundamental change in the API of SourceTables. 
          Show
          cmorrison Chris Morrison added a comment - Jenkins run:  https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/29086/pipeline
          Hide
          swinbank John Swinbank added a comment -

          Given that the columns being renamed were only added to ImageDifferenceTask very recently, and that creating them at all is hidden behind a config option, I think it's exceedingly unlikely that the change would be inconvenient to anybody. However, I just want to give Bob Armstrong and Yusra AlSayyad (on behalf of HSC) a heads up so they can object before this merges if they disagree.

          Show
          swinbank John Swinbank added a comment - Given that the columns being renamed were only added to ImageDifferenceTask very recently, and that creating them at all is hidden behind a config option, I think it's exceedingly unlikely that the change would be inconvenient to anybody. However, I just want to give Bob Armstrong and Yusra AlSayyad (on behalf of HSC) a heads up so they can object before this merges if they disagree.
          Hide
          rearmstr Bob Armstrong added a comment -

          No objection from me. These changes look good.

          Show
          rearmstr Bob Armstrong added a comment - No objection from me. These changes look good.
          Hide
          gkovacs Gabor Kovacs added a comment -

          Looks all right.

          Show
          gkovacs Gabor Kovacs added a comment - Looks all right.

            People

            • Assignee:
              cmorrison Chris Morrison
              Reporter:
              cmorrison Chris Morrison
              Reviewers:
              Gabor Kovacs
              Watchers:
              Bob Armstrong, Chris Morrison, Eric Bellm, Gabor Kovacs, John Swinbank
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel