Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16696

PhotoCalib produces negative flux errors for negative flux measurements.

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw

      Description

      The `PhotoCalib`, `instFluxToMaggies` method is missing an absolute value causing calibrated flux errors to be negative when fluxes are negative (as can happen in a difference image).

        Attachments

          Issue Links

            Activity

            Parejkoj John Parejko added a comment -

            Also, as part of this I should refactor the flux error calculation to take out the division by instFlux, so we don't get NaN flux for 0 counts.

            Parejkoj John Parejko added a comment -

            I'm going to do this as part of DM-16650, which is going on now.

            swinbank John Swinbank added a comment -

            “Won't Fix“-ing as a duplicate of DM-16650, which isn't quite true (this is a subset, rather than a duplicate), but it'll do.

            Parejkoj John Parejko added a comment -

            This is definitely not "won't fix": it's been done as part of DM-16650 (not a duplicate, it was just logical to do the work there), and will be marked "done" when that ticket is merged.

            Parejkoj John Parejko added a comment -

            DM-16650 was merged, and thus this fix is now in place (with an updated unittest to check for it).


              People

              • Assignee:
                Parejkoj John Parejko
                Reporter:
                cmorrison Chris Morrison
                Watchers:
                Chris Morrison, Eric Bellm, Jim Bosch, John Parejko, John Swinbank
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel