Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16865

Convert meas_extensions_psfex to numpydoc format

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Convert existing python docstrings to numpydoc format.

        Attachments

          Issue Links

            Activity

            dtaranu Dan Taranu added a comment -

            There's a lot of missing documentation, but most of it is likely obsolete. psfex and psfexStarSelector can't be imported as psfexLib seems to be broken (see DM-9840), so I commented out the doc generation for those files.

            Parejkoj John Parejko added a comment -

            See comments in the PR.

            Someone should probably file a ticket about removing this star selector...

            dtaranu Dan Taranu added a comment -

            I think DM-16899 was meant to cover removing both psfex.py and psfexStarSelector.py but Jim Bosch marked it as a duplicate of DM-9840. Otherwise, review suggestions adopted.

             

            dtaranu Dan Taranu added a comment - - edited

            For the record, this is the pull request with John's review. I deleted that branch because I accidentally named it DM-16824. Oh, and John Swinbank suggested that the metadata in PsfDeterminer might be of type lsst.daf.base.PropertySet, but I didn't verify that.


              People

              • Assignee:
                dtaranu Dan Taranu
                Reporter:
                dtaranu Dan Taranu
                Reviewers:
                John Parejko
                Watchers:
                Dan Taranu, John Parejko
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel