Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-16923

TSSW Jenkins Test servers not running build scripts

    Details

    • Templates:
    • Story Points:
      1.25
    • Epic Link:
    • Team:
      SQuaRE

      Description

      The TSSW Jenkins environment is failing to run build scripts.  After properly checking out all repos under test, when Jenkins moves to start the Build script (bash) there are failures in creating the virtualenv and the rest of the script fails to run.

      An example from the ts_pointing_component project

      No emails were triggered.
      [ts_pointing_common] $ /bin/bash /tmp/jenkins3039277301912326118.sh
      /tmp/jenkins3039277301912326118.sh: line 3: virtualenv: command not found
      /tmp/jenkins3039277301912326118.sh: line 4: ./venv/bin/activate: No such file or directory 

      After this, it fails to find any commands in the script.

       

      This issue effectively shuts down any work associated with Jenkins.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                rbovill Rob Bovill
                Reviewers:
                Rob Bovill
                Watchers:
                Andy Clements, Frossie Economou, Joshua Hoblitt, Rob Bovill, Wil O'Mullane
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel